Go Down

Topic: ethernet shield (Read 3 times) previous topic - next topic

kuxi

hallo,

versuche mittlerweise seit 4 wochen ohne erfolg das ethernet shield zum laufen zu bringen:
- arduino duemilanove + original ethernet shield (wiz5100)
- webserver und webclient examples (ip, gateway, subnet an mein netzwerk angepasst)
- ich kann das board nicht mal anpingen
- mittlerweile neues shield ohne erfolg getestet
- diverse shield reset experimente aus dem forum ohne erfolg getestet

ich bin am ende und hab keine ahnung was ich noch alles herumexperimentieren könnte, aber vielleicht gib es ja von euch da draußen noch einen tip????  ;)

Webmeister

Wie hast du die Verbindung zu deinem Netzwerk gemacht?
Hast du DHCP im Netzwerk?
Kannst du Rechner in deinem Netz anpingen?
Wie rufst du dein Arduino-Board auf?

IP vermutlich fix gesetzt.

Zum Test mal ein eigenes Netz, nur Arduino und PC über Hub oder Switch verbinden und prüfen.


sth77

Ich habe auch das originale Ethernetshield, da klappten sämtliche Sketche problemlos nach Anpassung der IP etc.. Wenn das Problem mit neuem Shield reproduzierbar ist, scheint es doch irgendwie an der Konfiguration zu liegen.
Mein Arduino-Blog: http://www.sth77.de/ - letzte Einträge: Teensy 3.0 - Teensyduino unter Window 7 - Teensyduino unter Windows 8

kuxi

- shield (x.y.z.88) hängt am router (x.y.z.1)
- dhcp: ja, habe es aber auch ohne versucht
- meinen rechner (x.y.z.9) kann ich anpingen
- Ethernet.begin(mac, ip, gateway, subnet); (subnet:255.255.255.0)
- auch wenn ich nur rechner und shield verbinde (switch, cross over) geht nichts

wenn ich mir die leds am shield so ansehe scheint alles zu passen:
-100m und fulld leuchten immer
- link und rx blinken
- was mir auffällt ist das tx nur dann blinkt wenn im netzwerk etwas geändert wird, wie z.b. ändern der ip addresse meines rechners, ???
  ist das normal??

df6ih

#4
Jan 31, 2011, 03:50 pm Last Edit: Jan 31, 2011, 03:51 pm by df6ih Reason: 1
Gibt es irgendwo eine Firewall ?

Meistens im Router ... http://ip  mit der eingesetzten IP sollte beantwortet werden, wenn Arduino-shield den Status 200 sendet

Go Up