Go Down

Topic: Aduino Uno + XBee Shield (Read 1 time) previous topic - next topic

wixspot

We purchased 2 Arduino Uno boards (Adafruit)+ 2 XBee Shields Series 2: http://www.robotshop.com/Arduino-Xbee-Shield-Wireless-Module-7.html

Has anyone figured out how to get these 2 talking? The documentation claims that series 2 is not compatible with series 1 and the tutorials online seem to be for series 1. When you click on the link http://arduino.cc/en/Guide/ArduinoXbeeShield  that says: For the XBee ZNet 2.5 ("Series 2") modules, see this configuration guide - the link http://www.humboldt.edu/~cm19/XBee%20setup.pdf does not exist.

This is a high school project and all we want to do is send a simple message from 1 board to the other, wireless and display that message on a LCD. The arduino uno and lcd work fine. Only the xbee shields do not seem to communicate.

Any ideas? Please help!!!


mowcius

The tutorial should work for the series 2 apart from you need to set one of your modules to router.

What have you set them to/done already?
Have you been using X-CTU to configure them or have you been configuring them by commands?

pracas

go to digi.com and download XCTU. Then configure both modules to be Znet end devices and it will start working.

Be The Change...

mowcius

Quote
Then configure both modules to be Znet end devices and it will start working.

Pretty sure it's not that simple when you're using the XBee shields. I think you have to use the command interface.

pracas

Quote
Pretty sure it's not that simple when you're using the XBee shields. I think you have to use the command interface.


well i think u can remove the ic off the arduino board and put the shield on usb mode[jumpers] and then use them together as a usb explorer.. don't have windows to try it thought but remember doing it that way...
Be The Change...

mowcius


Quote
Pretty sure it's not that simple when you're using the XBee shields. I think you have to use the command interface.


well i think u can remove the ic off the arduino board and put the shield on usb mode[jumpers] and then use them together as a usb explorer.. don't have windows to try it thought but remember doing it that way...

Yeah maybe you can - Anyway wixspot seems to have vanished.

Go Up