Go Down

Topic: upload fails on first install of Arduino Uno in Linux openSuse 11.3 (Read 1 time) previous topic - next topic


A few days ago my first Arduino arrived: Uno with ADRX kit.
After a lot of trouble, reading and searching, I finally got the Arduino IDE to select the connection (/dev/ttyUSB0) with the Arduino, open the terminal window, and compile a tutorial program.

My computer is an Intel i7 system with 6 GB ram running openSuse 11.3 64-bit. When the Arduino is powered on (using USB or the battery), it is already blinks the lights as if the Blink program already has been loaded

When uploading my first (or any) program, avrdude fails with :
# ....
# avrdude: Device signature = 0x000000
# avrdude: Yikes!  Invalid device signature.
The first part of the log is :
frans@SpinL2> Binary sketch size: 1018 bytes (of a 32256 byte maximum)
/usr/share/arduino-0022/hardware/tools/avrdude -C/usr/share/arduino-0022/hardware/tools/avrdude.conf -v -v -v -v -patmega328p -cstk500v1 -P/dev/ttyUSB0 -b115200 -D -Uflash:w:/tmp/build4969079493600480803.tmp/sample_01_Blink.cpp.hex:i

avrdude: Version 5.10, compiled on Jan 14 2011 at 16:39:50
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "/usr/share/arduino-0022/hardware/tools/avrdude.conf"
         User configuration file is "/home/frans/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/ttyUSB0
         Using Programmer              : stk500v1
         Overriding Baud Rate          : 115200
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
I have attached the complete log of the upload.

If I change in the terminal window the speed from 115200 to 57600, i get some readable characters when resetting the Arduino :   "....StandardFirmata_2_2_for_UNO_0_3....." (with the "..." indicating non-character bytes)
I changed the AVR chip for a spare one (wihtout pre-laoded blink program), does not help.

On my older Dell laptop running windows XP, I downloaded and installed the Arduino IDE in 20 minutes and uploaded the program successfully.

I noticed a difference in the version of avrdude on the windows system in the log:
  on windows : "Version 5.4-arduino"
  on Linux:        "version 5.10"        so without  "-arduino"

On Linux, i installed Arduino, avrdude, compiler and library from the repository given in the Arduino download page:
site: download.openSuse.org folder: /repositories/home:/kwk:/arduino/openSUSE_11.3 (I double checked that, had avrdude v5.5 (without "-arduino")  before, but that gave the same result.
The troubleshooting section of the Arduino help mentions that a modified version of avrdude is provided because the standard release does not query the Arduino signature correctly.

Could it be that avrdude in the repository for openSuse is not patched for Arduino? (see difference in versions "-arduino" )?
Any suggestions how to solve this, or how to test the connection with the Arduino?
thanks in advance,



I use OpenSUSE 11.3 as my main OS - I had no joy with the Arduino IDE from various repositories - the only one that works consistently for me is the 64-bit 0021 build from the Official Arduino downloads page http://files.arduino.cc/downloads/arduino-0021-2.tgz.


Thanks, andycheeze

I'll try that one too, after my linux system is running again and tried building from source :smiley-sad-blue:

(last week while downloading the source, my home partition got full, resizing the adjacent partition invalidated the partition table, am now copying the 1.5TB disk to a new backup over USB ( eSata fails on systemRescueCD after 250 MB) before trying to fix the partition table)

Go Up