Pages: [1]   Go Down
Author Topic: Unable to upload anything to arduino bt  (Read 1181 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 7
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm working on a project right now and after a bit of research i came across arduino bt and it seemed perfect for the job. So, i ordered one and received it yesterday. However, i haven't been able to upload ANYTHING to the board as i'm getting this error message:

Quote
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

I searched google and apparently that error message shows up whenever you've chosen the wrong port or board but i'm pretty sure i've chosen the correct settings. My board is an arduino bt w/ ATmega328 and i'm running windows ultimate 64bit.

I was already behind schedule and this is just making things worse. I thought i'm saving time by buying this board instead of having to program a microcontroller with a whole board full of electronics and in assembly but this is proving to be just as time consuming. I feel like i've wasted 200 dollars on a faulty product. This is totally unacceptable since you guys are advertising it as a no hassle, easy to use product but in reality is doesn't even support the most popular OS in the market.

Any help is appreciated.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 7
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

anybody?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 7
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Wow, this is really great. Buggy software paired with inactive support forum...
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

always the same problem and nobody gives a solution everyone washes his hands.
say it is the only error, but no one says anything about how to solve
so many smart people and nobody gives a solution
everyone says .... I like my work to others to give them

not alone
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Jeez, at least somebody could say something like "I have no clue what is wrong, sorry"

Aydin, I would suggest you return the arduino BT and don't look back...
Logged

Espoo, Finland
Offline Offline
God Member
*****
Karma: 7
Posts: 586
"Oops, try again..."
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have no clue what is wrong, sorry!
Does this make you feel better?

Maybe you provide some code for pros to check out? I'm sure you're not alone, but that kind of crying won't get you very far.
Should you try one more time, with another attide, try asking again and use the magic word?

Kari
Logged


The only law for me; Ohms Law: U=R*I       P=U*I
Note to self: "Damn! Why don't you just fix it!!!"

Offline Offline
Newbie
*
Karma: 0
Posts: 34
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I got the exact same problem on the Arduino BT-board. I used several hours and three different computers and it did not work on any one of these computers.

But my solution was to press the reset-button on the board not more than 0,5 seconds before I press the "upload"-button. I need to do this every time i try to transfer the program. I do not know why, but I hope I'll find a better solution in the feature.

But, I tried to do the same on another computer, but then I got the error. So I will not guarantee that it will work the first time. Try different computers and see if it helps.

I'm using Win7 32-bit.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have no clue what is wrong, sorry!
Does this make you feel better?

Maybe you provide some code for pros to check out? I'm sure you're not alone, but that kind of crying won't get you very far.
Should you try one more time, with another attide, try asking again and use the magic word?

Kari

This is the most unhelpful post I have yet seen on this forum.
Logged

Chile
Offline Offline
Edison Member
*
Karma: 35
Posts: 1251
Arduino rocks?
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

This is the most unhelpful post I have yet seen on this forum.

There aren't magicians here. Nobody can guess what is happening without the proper background of the problem.

Too much people is just asking and complaining like if someone was getting paid here for solving problems, wanting for quick and precise answers providing just a generic problem. If you check the past topics you can see what I mean.
Logged

My website: http://ried.cl

Espoo, Finland
Offline Offline
God Member
*****
Karma: 7
Posts: 586
"Oops, try again..."
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

This is the most unhelpful post I have yet seen on this forum.

Ok. Can I ask how did your posts helped here? I am trying to make people understand some basic manners here. If you want help, don't start with bad attitude, try to behave. That is the way you have a chance to get some help.
Those who can help, usually stops reading these after the first sentence...

Cheers,
Kari
Logged


The only law for me; Ohms Law: U=R*I       P=U*I
Note to self: "Damn! Why don't you just fix it!!!"

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

The Arduino BT on Windows can be tricky, because each PC may have a different bluetooth stack and hardware, some of which may not work well with the board.  As someone suggested, try resetting shortly before upload.  Have you paired it successfully and it has a COM port?  If there's a way you can see, in real time, whether the board is currently connected / paired or not, that may help get the timing right. 
Logged

Pages: [1]   Go Up
Jump to: