Go Down

Topic: Dudas transistor BC547 [SOLUCIONADO] (Read 6599 times) previous topic - next topic

comeollas

Feb 04, 2011, 09:16 pm Last Edit: Apr 30, 2012, 04:40 am by coleoptero Reason: 1
Buenas, estoy teniendo dudas haber si podeis echarme una mano y de paso entiendo el "porque ":

Tengo 1- Arduino UNO, 2 eth shields una es la ENC y la otra la oficial con wiznet y un rele activado con un BC547 (copiado del paper rele) veo las siguientes diferencias alimentando a 5V o a 7.5V (adaptador externo 5V 2A).

Con alimentador de 7.5V las dos eth shields van perfectas pero se calienta un monton el arduino y donde iran durante el verano puede que la temperatura sea 20grados mayor que donde hago las pruebas.

Con alimentacion 5V 2A con la enc no llega a encederse la tarjeta de red correctamente y la ethernet con wiznet que vende arduino como la oficial se enciende pero cae mucho el voltaje y no enciende el rele, la bobina del rele hace un pequeño click que no es suficiente.

Despues de todo el rollo hay va la pregunta: Veo que si alimento la base del transistor sin la resistencia si que funciona, es malo no poner esa resistencia si lo alimento con 5v?

complubot

Quote
Veo que si alimento la base del transistor sin la resistencia si que funciona, es malo no poner esa resistencia si lo alimento con 5v?


Los transistores se controlan por corriente, no por tensión. Esto es, tienes que calcular la resistencia de base para tener la corriente de colector necesaria cuando el transistor sature.

Un ejemplo. Si miramos las características del BC547 tenemos:

HFE = 110...800
VBE (sat) = 0,7..0,9V
VCE (sat) = 0,2..0,6V

Como veis hay una cierta dispersión entre los valores, esto es algo bastante normal ya que el proceso de fabricación no produce transistores idénticos

Imaginemos que tenemos un relé alimentado a 5V (en el colector del transistor) y que dicho relé necesita 40mA para funcionar. Como tenemos que poner un cierto margen vamos a calcular la resistencia de base (Rb) que necesitamos para 60mA de Intensidad de colector. Tomaremos valores medios de HFE = 400 y VBE (sat) = 0,8

Sabemos que Ic = HFE x Ib => Ib = 60 / 400 = 0,15mA como IB = (5-0,8)/Rb => Rb =  4,2V/0,15mA = 28K

El problema es que nos toque el "malo", esto es, el transistor que tiene un HFE de 100. En este caso, si no funciona con los cálculos, podemos ir bajando la Rb. Ya se sabe que "la electrónica es una ciencia exacta con un 20% de error" así que en la mayoría de los casos ponemos una Rb de 10K y funciona. Lo que nunca debemos hacer es poner una Rb por debajo de 1K ya que aún con el HFE más bajo, podríamos llegar a superar los 100mA de ICmax del BC547.
Centro de Robótica Educativa
www.complubot.com

caramono

Buenas:

En cuanto al transistor, mejor que lo ha explicado complubot, imposible :) . En los que he usado yo, los BC547 nunca bajaron de Hfe=300.

Lo que es raro es que se te caliente el arduino a 7.5v. ¿Has mirado con un polimetro el voltaje que te da el transformador? Mi transformador de los chinos, si lo pongo a 5, me da casi 8. Y si lo pongo a 7.5 me da mas de 10. A lo mejor te pasa algo parecido.

anv

#3
Feb 05, 2011, 01:11 pm Last Edit: Feb 06, 2011, 12:01 pm by anv Reason: 1

Buenas, estoy teniendo dudas haber si podeis echarme una mano y de paso entiendo el "porque ":

Con alimentador de 7.5V las dos eth shields van perfectas pero se calienta un monton el arduino y donde iran durante el verano puede que la temperatura sea 20grados mayor que donde hago las pruebas.


Recuerda que cuanto más alta la tensión con que lo alimentes, más se va a calentar el regulador. La cosa es muy sencilla: el sistema funciona con 5V. Si le pones 7,5 el regulador tendrá que producir una caida de 2,5v. Si multiplicas 2,5 por la corriente que esté consumiendo, tendrás la cantidad de Watts que tendrá que disipar. Y tal como dices, la temperatura ambiental es muy importante.


Con alimentacion 5V 2A con la enc no llega a encederse la tarjeta de red correctamente y la ethernet con wiznet que vende arduino como la oficial se enciende pero cae mucho el voltaje y no enciende el rele, la bobina del rele hace un pequeño click que no es suficiente.


Si con la fuente de 5V te cae la tensión debe ser porque no es capaz de entregar 2A como dice. 2A es una enormidad para esto. Sin embargo se me ocurre una alternativa: podrías alimentar el relé directamente con la tensión de la fuente sin pasar por el regulador de Arduino. De esta forma evitas que la corriente necesaria para el relé pase por el regulador del Arduino.

Por ejemplo, en este diagrama: http://www.arduino.cc/playground/uploads/Learning/relays.pdf la patita que dice Relay Power V+ puede ir directa a la fuente para que no pase por el regulador de Arduino. Puedes poner la fuente de 7,5V y el consumo del Arduino no debería ser tanto como para que se caliente el regulador.


comeollas

#4
Feb 05, 2011, 03:43 pm Last Edit: Feb 05, 2011, 11:51 pm by comeollas Reason: 1
Bua!! esto si an sido unas respuestas como dios manda jajaja

Como dicen probe de bajar la resistencia de 10k a 1k y si me funciona ahora alimentando a 5V y el arduino no se calienta, como el circuito solo lo utilizo pocas veces para resetear la luz de una toma de enchufes supongo k nada se sobrecalentara en el transistor al activarlo solo 5 segundos para quitar la luz y volver a dejar el rele con el normalmente abierto.

Este sistema me ha quitado unos dolores de cabeza "que pa que", tenemos arriba en campanarios de iglesias puntos de acceso y esas iglesias instalaciones de luz malisimas que cada dos por tres se va y vuelve la luz... cada 2 semanas o 3 algun aparato se keda pajaro y teniamos que ir a kitar la luz y darle de nuevo... hay quien dice que el arduino asi esta desaprobechado (razon tiene) pero juer es la solucion mas economica que he encontrado que yo mismo pueda hacerla y entender porque hace lo que hace (y ahora ya entiendo hasta para que sirve la R1!!!).

Ahora probare de hacerme una shield alimentando los reles directos en lugar del arduino para que vaya mas tranquilo :) (tb tengo k mirar ese transformador que voltaje saca por si las moscas ).

Gracias a todos, espero aprender muuuuucho jeejje

comeollas

mare mia el transformador ese da 12.43V en lugar de 7.5v xDDD

Que wai... tengo una fuente de 12v!!! ¬_¬u



anv


Ahora probare de hacerme una shield alimentando los reles directos en lugar del arduino para que vaya mas tranquilo :) (tb tengo k mirar ese transformador que voltaje saca por si las moscas ).


Nota que el Arduino, al lado de las entradas analógicas, tiene un conector que dice VIN. Si no me equivoco ese conector va directo a la entrada de alimentación antes de pasar por el regulador. Lo unico que hay entre medio es un diodo por lo que veo en los esquemas. Ahí puedes conectar la alimentación del relé y así evitas pasar por el regulador.

anv



Ahora probare de hacerme una shield alimentando los reles directos en lugar del arduino para que vaya mas tranquilo :) (tb tengo k mirar ese transformador que voltaje saca por si las moscas ).


Nota que el Arduino, al lado de las entradas analógicas, tiene un conector que dice VIN. Si no me equivoco ese conector va directo a la entrada de alimentación antes de pasar por el regulador. Lo unico que hay entre medio es un diodo por lo que veo en los esquemas. Ahí puedes conectar la alimentación del relé y así evitas pasar por el regulador.


mare mia el transformador ese da 12.43V en lugar de 7.5v xDDD
Que wai... tengo una fuente de 12v!!! ¬_¬u


Los transformadores comunes rara vez dan la tensión que dicen. La tensión depende del consumo y si los mides sin carga probablemente te den mucho más. Las fuentes electrónicas (que no llevan transformador) son mucho más estables, aunque como contrapartida generan interferencias de alta frecuencia que en general no son problemas pero por ejemplo afectan a los PLCs.

comeollas

Quote

Ahora probare de hacerme una shield alimentando los reles directos en lugar del arduino para que vaya mas tranquilo :) (tb tengo k mirar ese transformador que voltaje saca por si las moscas ).

Quote

Nota que el Arduino, al lado de las entradas analógicas, tiene un conector que dice VIN. Si no me equivoco ese conector va directo a la entrada de alimentación antes de pasar por el regulador. Lo unico que hay entre medio es un diodo por lo que veo en los esquemas. Ahí puedes conectar la alimentación del relé y así evitas pasar por el regulador.



Alguno podeis confirmarmelo? Que esto me quita el dolor de cabeza de tener que cortar el cable de alimentacion +5v para que vaya a la shied de reles y al arduino :P

Gracias por la respuesta!

Igor R

+1 a la confirmación que Vin es la tensión de la entrada de alimentación externa (pasando a través de un diodo).

;)

comeollas

Puesss +1 a las respuestas y ayuda jejejeje

Gracias por todooooo!! y a seguir aprendiendo!!

Go Up