Go Down

Topic: Hacking the IDE: Help with Ant (Read 2924 times) previous topic - next topic


Feb 05, 2011, 03:21 am Last Edit: Feb 05, 2011, 03:23 am by effection Reason: 1
I've been trying to add some GIT functionality to the IDE the last few days. I have created a working test project that runs fine.

I have added the classes i created that implement the jgit library then added jgit  to the lib folder and modified the build.xml classpath for the javac on the app directory
Code: [Select]
classpath="../core/core.jar; lib/jgit-0.10.1.jar; etc etc

My code compiles FINE! But when i go to execute the produced windows executable it pops up the splash using launch4j then the actual java app dies/never appears.

I know the output is missing a reference or something but i can't work out how to resolve this at all  :smiley-eek:

Any help would be appreciated.

I have been able to load the ant project into eclipse and provide my modifcations there and it compiles and works! But i would like to get it generating the correct output without the need for eclipse  :0


Launch4j provides some debug options, these may help track down your problem:




Worked a treat! Found my problem  :)


I'm summarizing the research I did to fix this error.

Disable/delete unnecessary COM ports.

Unplug Bluetooth adapter (worked for me).
Close/Disable Bluetooth software, e.g. Bluesoleil.exe and btntservice.exe

Delete preferences.txt
Windows 7: C:\Users\<user>\AppData\Roaming\Arduino\preferences.txt
Windows XP: C:\Documents and Settings\<user>\Application Data\Arduino\preferences.txt.

Edit the file outside of a version control system.
Subversion: http://arduino.cc/forum/index.php/topic,52152
Git: http://arduino.cc/forum/index.php/topic,51135

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131