Pages: [1]   Go Down
Author Topic: XBee series 2 and X-CTU issues  (Read 2158 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I am having problems with configuring the xbee using X-CTU. After reading various threads and trying things out I am still stuck.
I really need help with this as I need to use XBee for a school project and I am still noob with arduino.

I am using:
XBee shield http://www.sparkfun.com/products/9976
XBee series 2 (it states itself as S2 underneath XBee logo on the chip; it doesn't say PRO or series 2)
Arduino Diecimila

When I clicked on Test/Query on the USB Serial Port, the resulting message says:
Modem type = name unknown(id=....................some number)
Modem firmware version = (left blank)

http://antipastohw.blogspot.com/2009/01/xbee-shield-to-xbee-shield.html

I was following the tutorial above but when I tried the "write" command I receive this reply:
Getting modem type....OK
Programming modem...Lost communication with modem
Write Parameters...Failed

I also tried "+++" command on Terminal tab page and there is no feedback from the program.

Please help, thank you.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 15
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

What serial port speed are you using?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Do you mean baud rate? I've tried pretty much every single baud rate option in the program has but it still doesn't work. Whenever the info box popped up asking me to reset the xbee, the box doesn't disappear either. I am also using Lilypad 328 with another XBee module and it always replies me with "Programming modem...Detected baud rate difference.
Make sure PC and modem baud rate is set correctly" whenever I used "write" command even though I went through different baud rate option. I am beginning to fear that I have a bricked xbee module.
Logged

North Yorkshire, UK
Offline Offline
Faraday Member
**
Karma: 104
Posts: 5531
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Whenever the info box popped up asking me to reset the xbee, the box doesn't disappear either.
Did you reset the XBee as it asked then?
Logged

Palermo
Offline Offline
God Member
*****
Karma: 3
Posts: 764
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I remember I had similar problems when I loaded a API firmware, without checking the API option on X-CTU, and vice versa
Logged

Gianfranco

Pages: [1]   Go Up
Jump to: