Pages: [1]   Go Down
Author Topic: 3.3 v en Arduino Nano  (Read 3140 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Jr. Member
**
Karma: 1
Posts: 92
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola a todos.
Tengo una duda con esta salida de tensión de la nano. He leido que esta salida sólo está activa si tenemos conectada la placa al ordenador por el USB. He comprobado que esto no es cierto porque cuando la alimento a baterías, también tengo esta tensión. ¿Sabéis cuanta corriente puede suministrar la placa en estas circunstancias (alimentada con batería)? El caso es que le he puesto un módulo GPS sencillito que consume 81mW a 3 v...La verdad es que no se hacer bien la conversión a corriente con este dato. Cuando lo conecto, los leds que tengo conectado en la placa se vienen a bajo cuando el GPS envía información...
« Last Edit: April 29, 2012, 10:02:30 pm by coleoptero » Logged

0
Offline Offline
Full Member
***
Karma: 1
Posts: 105
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Si no voy equivocado (hace 15 años que hice electronica y no hice nada mas smiley-razz) Intensidad=Potencia / Voltaje asi sabras los A que consume (27mA consume ese GPS si se alimenta a 3V).

http://arduino.cc/es/Main/ArduinoBoardNano
Aqui puedes ver sus caracteristicas, cada pin puede dar 40mA igual que el duemilanove/UNO.

Como dices segun las caracteristicas esa salida no sera alimentada copio el texto debajo.

"El chip FTDI FT232RL que posee el Nano solo es alimentado si la placa esta siendo alimentada usando el cable USB. como resultado, cuando se utiliza una fuente externa (no USB), la salida de 3.3V (la cual es proporcionada por el chip FTDI) no está disponible y los pines 1 y 0 parpadearán si los pines digitales 0 o 1 están a nivel alto."


Podrias coger un alimentador que tiene salida USB como el de los cargadores de mobiles te pongo el mas economico que encontre en ebay:

http://cgi.ebay.com/USB-AC-Power-Wall-Adapter-MP3-ipod-Charger-EU-Plug-JE0-/300509677363?pt=Other_MP3_Player_Accessories&hash=item45f7c5c733

Vale 1€ con envio incluido, solo da 0.5Amperios siempre mejor que tenga 1 o 2A.


Sobre el tema de que los leds pierden intensidad no se si pasaria alimentando por usb. Si lo alimentas externamente con fuente de 7 a 12V (mejor 7 que 12 ya que se calentara menos el arduino) pierdes esos 3.3v por desgracia smiley-sad

Un saludo, y haber si alguien tiene mas informacion al respecto smiley-wink
Logged

Offline Offline
Edison Member
*
Karma: 23
Posts: 1375
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Según el esquemático del Arduino Nano v3 y v2.3, la salida de 3.3V siempre estará activa independientemente de por donde se alimente.
Ésta salida da como mucho 50mA, asi que depende de lo que lo cargues si te servirá o no.
Logged

Mercadillo electrónico. Kit iniciación a Arduino, shield LCD a color y más cosas!

0
Offline Offline
Jr. Member
**
Karma: 1
Posts: 92
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Efectivamente, cuando conecto el USB no tengo este problema. Lo del tema del parpadeo leve de los leds creo que se debe a la caida de tensión cuando no es capaz de suministrar la corriente que necesita el dispositivo conectado a la línea de 3.3v, cosa que no entiendo puesto que según las cuentas que hemos hecho y la corriente de la que disponemos en esa línea, debería funcionar bien.
Lo del tema de conectarlo por usb...negativo, necesito necesariamente alimentarlo con baterías...
Logged

Offline Offline
Edison Member
*
Karma: 23
Posts: 1375
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Los leds los tienes conectados a 5V o 3.3V?
Logged

Mercadillo electrónico. Kit iniciación a Arduino, shield LCD a color y más cosas!

0
Offline Offline
Jr. Member
**
Karma: 1
Posts: 92
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Los tengo conectados a 5v (son activados por una salida digital). El GPS es lo único conectado a 3.3v
« Last Edit: February 06, 2011, 06:00:06 pm by javilolo » Logged

0
Offline Offline
Jr. Member
**
Karma: 1
Posts: 92
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bueno, tras mis investigaciones he descubierto lo siguiente:
1- Tenía puesta una bobina de 100mH en serie en la línea de alimentación para prevenir interferencias  de RF en dicha línea (según he leido por ahí). Esto impedía que los picos de consumo que el GPS necesita en cada transmisión de datos y el suministro de corriente a la paca en general desde una batería se limitase (debe ser eso de que la bobina impide cambios bruscos de corriente al pasar por ella). Al quitar dicha bobina va bien.
2- Tengo un LM35 conectado a una analógica y me estaba dando lecturas con unos 4 o 5 grados sobre la que medía física el sensor...antes había funcionado bien...¿? SOLUCIÓN: LAS BATERÍAS. Si uso baterias lipo, la lectura es ok, pero si utilizo unas alkalinas de marca blanca (no se si otra marca de más calidad tendrá el mismo problema) parece que meten ruido a la línea de alimentación.

Espero que os sirva si alguna vez os pasa algo similar.

P.D. Por cierto, a mi me pasa que si alimento con el USB, la lectura del LM35 tampoco es correcta y supuse que la línea de 5v del USB de mi ordenador también metía ruido...a vosotros os pasa?
« Last Edit: February 07, 2011, 02:48:37 pm by javilolo » Logged

Pages: [1]   Go Up
Jump to: