Pages: [1]   Go Down
Author Topic: IDE Crashes during uploads versions 21, 22 OSX 10.6.5-6  (Read 4558 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

trying to upload any sketch to a mega2560 that has been uploaded to successfully a couple of days ago

I never see the TX or RX lights go on the mega, the IDE just closes without a message

Anyone up for a mystery?

This is excerpt from the report


Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x00000000b213dba0
Crashed Thread:  23  Java: Thread-4

Application Specific Information:

Java information:
 Exception type: Bus Error (0xa) at pc=00000000311dd90c
 
 Java VM: Java HotSpot(TM) Client VM (17.1-b03-307 mixed mode macosx-x86)
 
Current thread (0000000005821000):  JavaThread "Thread-4" [_thread_in_native, id=-1308377088, stack(00000000b1f3c000,00000000b203c000)]
Stack: [00000000b1f3c000,00000000b203c000]
Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j  gnu.io.RXTXPort.interruptEventLoop()V+0
j  gnu.io.RXTXPort.removeEventListener()V+55
j  gnu.io.RXTXPort.close()V+91
j  processing.app.Serial.dispose()V+57
j  processing.app.debug.Uploader.flushSerialBuffer()V+64
j  processing.app.debug.AvrdudeUploader.uploadViaBootloader(Ljava/lang/String;Ljava/lang/String;)Z+241
j  processing.app.debug.AvrdudeUploader.uploadUsingPreferences(Ljava/lang/String;Ljava/lang/String;Z)Z+49
j  processing.app.Sketch.upload(Ljava/lang/String;Ljava/lang/String;Z)Ljava/lang/String;+14
j  processing.app.Sketch.exportApplet(Ljava/lang/String;Z)Z+88
j  processing.app.Sketch.exportApplet(Z)Z+8
j  processing.app.Editor$DefaultExportHandler.run()V+29
j  processing.app.Editor$DefaultExportHandler.run()V+88
j  java.lang.Thread.run()V+11
v  ~StubRoutines::call_stub
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Update, I've tried it with a known-good duemilanove as well, its not the boards, two different USB chips.. Good software mystery
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

In the Console application (system log), do you see any RXTX messages when you start the Arduino software?  Do you have a copy of an RXTX jar (e.g. comm.jar or something with RXTX in the name) or native library (librxtxSerial.jnilib, I think) anywhere?  It might be a conflict between the Java part of the RXTX library and the native part.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

You got it,

2/7/11 6:07:15 PM   [0x0-0x13d13d].cc.arduino.Arduino[2000]   [JavaAppLauncher] Requested [1.5*], launching in [1.6] instead.
2/7/11 6:07:21 PM   [0x0-0x13d13d].cc.arduino.Arduino[2000]   WARNING:  RXTX Version mismatch
2/7/11 6:07:21 PM   [0x0-0x13d13d].cc.arduino.Arduino[2000]      Jar version = RXTX-2.2pre1
2/7/11 6:07:21 PM   [0x0-0x13d13d].cc.arduino.Arduino[2000]      native lib Version = RXTX-2.2pre2
2/7/11 6:08:24 PM   [0x0-0x13d13d].cc.arduino.Arduino[2000]   Binary sketch size: 1018 bytes (of a 30720 byte maximum)
2/7/11 6:08:24 PM   [0x0-0x13d13d].cc.arduino.Arduino[2000]   Invalid memory access of location 0xb21bfba0 eip=0x312de90c
2/7/11 6:08:24 PM   com.apple.launchd.peruser.501[166]   ([0x0-0x13d13d].cc.arduino.Arduino[2000]) Job appears to have crashed: Segmentation fault
2/7/11 6:08:25 PM   ReportCrash[2127]   Saved crash report for JavaApplicationStub[2000] version 0022 (0022) to /Users/jstkatz/Library/Logs/DiagnosticReports/JavaApplicationStub_2011-02-07-180825_Jonathan-Katzs-MacBook-Pro.crash


Now I'm not really sure how to specify which one to use ( delete the other? )

And I'm also not sure which to specify, once I figure out how to do that

I'm working on it on this side and will post an update if I get it figured out
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I think I've narrowed it down to a driver that the reprap host software installs, here is a log of it installing, I've found a couple of the files it has installed and moved them to trash but it hasn't helped

2/7/11 6:19:12 PM   Installer[2275]   @(#)PROGRAM:Install  PROJECT:Install-594.1
2/7/11 6:19:12 PM   Installer[2275]   @(#)PROGRAM:Installer  PROJECT:Installer-430.1
2/7/11 6:19:12 PM   Installer[2275]   Hardware: MacBookPro6,2 @ 2.40 GHz (x 4), 4096 MB RAM
2/7/11 6:19:12 PM   Installer[2275]   Running OS Build: Mac OS X 10.6.6 (10J567)
2/7/11 6:19:12 PM   Installer[2275]   RepRap  Installation Log
2/7/11 6:19:12 PM   Installer[2275]   Opened from: /Applications/reprap-mendel-20100806/RepRap Drivers.mpkg
2/7/11 6:19:18 PM   Installer[2275]   <ZeroSliderSplitView: 0x10023f390>: the delegate <TargetSelectPage: 0x100467c50> was sent -splitView:resizeSubviewsWithOldSize: and left the subview frames in an inconsistent state:
2/7/11 6:19:18 PM   Installer[2275]   Split view bounds: {{0, 0}, {402, 104}}
2/7/11 6:19:18 PM   Installer[2275]       Subview frame: {{0, 0}, {0, 32}}
2/7/11 6:19:18 PM   Installer[2275]       Subview frame: {{0, 0}, {402, 104}}
2/7/11 6:19:18 PM   Installer[2275]   The outer edges of the subview frames are supposed to line up with the split view's bounds' edges. NSSplitView is working around the problem, perhaps at the cost of more redrawing. (This message is only logged once per NSSplitView.)
2/7/11 6:19:48 PM   Installer[2275]   ================================================================================
2/7/11 6:19:48 PM   Installer[2275]   User picked Standard Install
2/7/11 6:19:48 PM   Installer[2275]   Choices selected for installation:
2/7/11 6:19:48 PM   Installer[2275]      Upgrade: "RepRap"
2/7/11 6:19:48 PM   Installer[2275]      Upgrade: "FTDIUSBSerialDriver_10_6"
2/7/11 6:19:48 PM   Installer[2275]      Upgrade: "librxtxSerial"
2/7/11 6:19:48 PM   Installer[2275]      Upgrade: "RXTXcomm"
2/7/11 6:19:48 PM   Installer[2275]   ================================================================================
2/7/11 6:19:49 PM   Installer[2275]   Configuring volume "Macintosh HD"
2/7/11 6:19:49 PM   Installer[2275]   Free space on "Macintosh HD": 83.93 GB (83930181632 bytes).
2/7/11 6:19:49 PM   Installer[2275]   Create temporary directory "/var/folders/1t/1tBEp4r1GkWyzZF8sRF54++++TI/-Tmp-//Install.22752mYgm3"
2/7/11 6:19:49 PM   Installer[2275]   IFPKInstallElement (5 packages)
2/7/11 6:19:49 PM   installd[2283]   PackageKit: ----- Begin install -----
2/7/11 6:20:05 PM   com.apple.kextd[10]   Cache file /System/Library/Caches/com.apple.kext.caches/Directories//System/Library/Extensions/IOKitPersonalities_i386.ioplist.gz is out of date; not using.
2/7/11 6:20:05 PM   com.apple.kextd[10]   Rescanning kernel extensions.
2/7/11 6:20:05 PM   com.apple.kextd[10]   Cache file /System/Library/Caches/com.apple.kext.caches/Directories//System/Library/Extensions/IOKitPersonalities_i386.ioplist.gz is out of date; not using.
2/7/11 6:20:51 PM   kernel   FTDIUSBSerialDriver:        0  4036001 start - ok
2/7/11 6:20:53 PM   com.apple.kextcache[2291]   JMicronATA.kext does not declare a kernel dependency; using com.apple.kernel.6.0.
2/7/11 6:21:00 PM   com.apple.kextcache[2291]   Created mkext archive //System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext.
2/7/11 6:21:00 PM   com.apple.kextcache[2289]   /: no supported helper partitions to update.
2/7/11 6:21:00 PM   installd[2283]   Installed "RepRap" ()
2/7/11 6:21:00 PM   installd[2283]   PackageKit: ----- End install -----
2/7/11 6:21:01 PM   Installer[2275]   Running install actions
2/7/11 6:21:01 PM   Installer[2275]   Removing temporary directory "/var/folders/1t/1tBEp4r1GkWyzZF8sRF54++++TI/-Tmp-//Install.22752mYgm3"
2/7/11 6:21:01 PM   Installer[2275]   Finalize disk "Macintosh HD"
2/7/11 6:21:01 PM   Installer[2275]   Notifying system of updated components
2/7/11 6:21:02 PM   Installer[2275]   
2/7/11 6:21:02 PM   Installer[2275]   **** Summary Information ****
2/7/11 6:21:02 PM   Installer[2275]     Operation      Elapsed time
2/7/11 6:21:02 PM   Installer[2275]   -----------------------------
2/7/11 6:21:02 PM   Installer[2275]          disk      0.01 seconds
2/7/11 6:21:02 PM   Installer[2275]        script      0.00 seconds
2/7/11 6:21:02 PM   Installer[2275]          zero      0.01 seconds
2/7/11 6:21:02 PM   Installer[2275]       install      72.10 seconds
2/7/11 6:21:02 PM   Installer[2275]       -total-      72.12 seconds
2/7/11 6:21:02 PM   Installer[2275]   
2/7/11 6:21:02 PM   Installer[2275]   IFDInstallController 4388F0 state = 5
2/7/11 6:21:02 PM   Installer[2275]   Displaying 'Install Succeeded' UI.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

On second or third thought, I can remove all of that package ( i think ) and  it dosen't fix it, I've tried reinstalling arduino multiple times, can't reinstall java on osx...
Logged

Pages: [1]   Go Up
Jump to: