Pages: [1]   Go Down
Author Topic: Stepper motor troubles, i need ideas.  (Read 802 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hey everyone, im new to the forum. I came here to seek help running stepper motors with my arduino. I have a 6 wire unipolar SM, ive isolated the different coils with my ohm meter and this is what ive done so far... the stepper hookup connector is (red,brown,blue,yellow,white,white), red/brown/white = one coil with center tap, blue/yellow for the other. Ive hooked it up with a ULN2003A....
O1 = Red
O2 = Brown
O3 = Blue
O4 = Yellow
with whites on common.

and the arduino at 1,2,3,4 to the ULN2003A at I4,I3,I2,I1

I ran a simple program in arduino that pulses...
1000
0100
0010
0001
The stepper takes two steps forwards and two steps back.
Ive reversed the motor coils and it still does the same thing, ive reversed the logic inputs and still the same result.
Im really having a hard time with this, anyone have any suggestions? I'm kinda stumped on where i should go from here...

Thanks.
-Nick
Logged

France
Offline Offline
Faraday Member
**
Karma: 39
Posts: 3605
There is an Arduino for that
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
I ran a simple program in arduino that pulses...
1000
0100
0010
0001
Well you're wrong with that sequence, look at the link below:
http://www.google.fr/imgres?imgurl=http://www.8051projects.net/stepper-motor-interfacing/stepper-coils.jpg&imgrefurl=http://www.8051projects.net/stepper-motor-interfacing/introduction.php&usg=__MhQYun-Tg-EqsPLhKko5PLE6P1E=&h=279&w=289&sz=26&hl=fr&start=9&zoom=1&um=1&itbs=1&tbnid=6FhvXUU8gS1CFM:&tbnh=111&tbnw=115&prev=/images%3Fq%3Dstepper%2Bmotor%2Bunipolar%26um%3D1%26hl%3Dfr%26newwindow%3D1%26client%3Dfirefox-a%26rls%3Dorg.mozilla:fr:official%26tbs%3Disch:1&ei=-rdPTeuyAYX2sgaM4_yeDw
Logged

Manchester (England England)
Offline Offline
Brattain Member
*****
Karma: 631
Posts: 34473
Solder is electric glue
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Or for an alternative explanation see:-
http://www.thebox.myzen.co.uk/Workshop/Motors_3.html
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

i assume you meant i need to run...
1100
0110
0011
1001

I thought this was just a higher torque version what i originally ran?
I still get the same problem, the shaft just goes back and forth, this time more violently.
Do you think the problem is in the sequence or in the wiring?

Thanks for your help.
-Nick
Logged

Manchester (England England)
Offline Offline
Brattain Member
*****
Karma: 631
Posts: 34473
Solder is electric glue
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Do you think the problem is in the sequence or in the wiring?

Either but they are both the same thing if you think about it.

Try swapping motor pairs, there are a lot of combination to try.
Logged

Pages: [1]   Go Up
Jump to: