Go Down

Topic: Problem with Sanguino, FTDI Cable, Fedora (Read 2755 times) previous topic - next topic

SimeonK

Hello,

I made a Sanguino on breadboard with ftdi cable connection. When i try to upload some sketch, i receive an error:
Code: (a) [Select]
avrdude: Device signature = 0x000000
avrdude: Yikes!  Invalid device signature.
         Double check connections and try again, or use -F to override
         this check.

My system is
Code: (uname -a) [Select]
Linux MyPC.home 2.6.35.10-74.fc14.x86_64 #1 SMP Thu Dec 23 16:04:50 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

I have Arduino Duemilanove and it works with my system, without any changes ( naturally i have selected the board from menu ).
On Windows there are no problems - neither with Arduino nor Sanguino.

Here is a list of related packs
Code: (yum list installed rxtx avr-* arduino* avrdude) [Select]

arduino.noarch                                                                       0021-2.fc14                                                                            @updates
arduino-core.noarch                                                                  0021-2.fc14                                                                            @updates
arduino-doc.noarch                                                                   0021-2.fc14                                                                            @updates
avr-binutils.x86_64                                                                  2.21-1.fc14                                                                            @updates
avr-gcc.x86_64                                                                       4.5.1-2.fc14.1                                                                         @updates
avr-gcc-c++.x86_64                                                                   4.5.1-2.fc14.1                                                                         @updates
avr-libc.noarch                                                                      1.7.0-1.fc14                                                                           @fedora
avrdude.x86_64                                                                       5.10-2.fc13                                                                            @fedora
rxtx.x86_64                                                                          2.2-0.3.20100211.fc14                                                                  @updates


Any ideas?

Thanks,
Simeon

madworm

FTDI cable = RTS instead of DTR right ?

Auto reset has never worked for me with that cable on linux. But I haven't tried it for quite a while. There's some info on the playground though.

I suggest getting an ISP programmer and forget worrying about bootloaders.
• Upload doesn't work? Do a loop-back test.
• There's absolutely NO excuse for not having an ISP!
• Your AVR needs a brain surgery? Use the online FUSE calculator.
My projects: RGB LED matrix, RGB LED ring, various ATtiny gadgets...
• Microsoft is not the answer. It is the question, and the answer is NO!

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy