Go Down

Topic: AR1010 problem .. Please help (Read 277 times) previous topic - next topic

Arduinoslfan

Nov 30, 2017, 12:50 pm Last Edit: Dec 02, 2017, 11:27 am by Arduinoslfan
Hi All,

I'm new to arduino. I've soldered some wires to ar1010 chip.I connected wires to arduino and 3.5mm jack as per the guide. For the code I've used below code. I can compile it without any issue. Upon uploading the code to board I dint hear any sound coming through earphones. I've used I2C scanner and it identifies device is connected.Please guide me to solve this issue.Many thank

DVDdoug

I'm not familiar with the chip but I just took a quick look at the datasheet.

Did you by a chip or a board assembly?    If you just have a chip, did you add the crystal, LC tuning components, and the other required shtuff?  Do you have an antenna?

I didn't see anything that says it can drive headphones, did you see that somewhere?   You might try plugging it into your stereo, or the audio inputs on your TV, or you can use "powered" computer speakers, etc.

Arduinoslfan

I bought this from ebay.. it looks like this

https://www.ebay.com/itm/FM-76-108MHz-AR1010-FM-Radio-Receiver-Module-replace-TEA5767-AU/232450334523?hash=item361f1e9f3b:g:xtEAAOSwVEVZlAWI

It can drive small earphones.

Many Thanks

slipstick

O.K. so it's not a TEA5767. Do you have the bare AR1010 or is it on a breakout board from somewhere?

What makes you think that it's compatible with the TEA5767 library?

Steve


Arduinoslfan

#4
Dec 01, 2017, 06:53 am Last Edit: Dec 01, 2017, 09:29 am by Arduinoslfan
Hi Steve,

This is what I bought



I managed to find its library.

My bad!
I've mistaken AR1010 with tea5767
Apologies.
can I used the previous code with slight modification?

Thanks All

Go Up