Pages: [1]   Go Down
Author Topic: avrdude: stk500_getsync(): not in sync: rep=0x30 avrdude :stk500_disable(): pro  (Read 1143 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

To those who had been caught with this problem:

avrdude: stk500_getsync(): not in sync: rep=0x30
avrdude :stk500_disable(): protocol error , expect=0x14, resp=0x51

Make sure your firewall and anti-virus software are not blocking the uploading!

I know it may sound silly, but that was what happened to me. I tried one whole day trying to upload the "Blink" onto the board, and end up realising that my Avira AntiVir was blocking it...

Disabled it and everything is fine now.

So, don't miss out this small bit if you have the same problem!
Logged

Germany-South
Offline Offline
Newbie
*
Karma: 0
Posts: 1
German Roboteer, Electronic, Hobby-Builder, Mythbusters-Fan, AVR
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo,

i had the same error when uploading the basic sketch blink to the arduino uno board.
I mounted four standard screws (spaceholders/pcb-board-tubes with screw) on the board
(the ones with 6 edges). It seems, that one of them made a short-circuit to some pcb-layers on the board, so i removed them so that the board were just the one which i buyed. I put the USB-cable into PC (my laptop) and then:  the bing sound cames and the FTDI-driver was installed correctly on one free new COM-Port.  I had a look to  the PC's  control-panel within system, manager, comports... show the new installed USB driver which works now perfekt. This port i remembered and put manually into the file: preferences.txt  (you find it in the arduino software
under File - Preferences  in the window below under: More preferences can be edit under....
In this file, just open with editor from windows and below in the editor is the   serial.port=COM...
here you write the remembered COM-Port into (be sure the arduino-software is not running!)
then restart the ard-soft and upload the software, the error should be away.  (I have a uno-board, so it should be the right setting under tools-board..


Bye iZapper
Logged

Let's Test.

Texas
Offline Offline
Newbie
*
Karma: 0
Posts: 2
With Angry Birds, I can kill two stones with one bird.
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

My solution was different.  The Arduino 1.0 driver always installs com port 3.  My laptop has a Modem Port set to com 3.  I deleted the software modem driver and re-installed the arduino driver.  (Note: I had tried to re-install the drive several times before and tried different com ports.)  This fixed my problem.  Perhaps the Arduino folks should choose a different com port by default.

charlie
Logged

Pages: [1]   Go Up
Jump to: