Go Down

Topic: Can't upload sketch (Read 423 times) previous topic - next topic

SamBrownADK



Suddenly today.. I can not upload a sketch to an Uno. I have several, I am able to upload the sketch to other Uno's I have, but not this one.

1.8.1 is the IDE.

Here is the error I get.

Please note: Pin 13 does flash when up loading... just at the end I get this error and the updated sketch is never uploaded.

To keep things simple I am now trying to just upload the Blink program in examples.

There is noting but the USB cable attached to the Uno.

Any advice / info on why this is happening would be great.

Code: [Select]


Sketch uses 926 bytes (2%) of program storage space. Maximum is 32256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x30
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x0f
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x10
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x20
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x0f
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x10
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x30
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x0f
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x10
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x20
An error occurred while uploading the sketch

johnfdsouza777

I have the exact same problem with Arduino UNO with IDE 1.8.5. I tried several times to upload once in a way it uploads but mostly not.

ballscrewbob

@johnfdsouza777
Do you see how SamBrownADK asked and included some valuable information ?

A "me too" does nothing for anyone wanting to help. If yours is not the exact same error / OS etc etc. then consider staring your own post.


@SamBrownADK A little more info if you please. OS, type of USB ports etc. Are the others real ones and this a clone ? did you remove anything connected to it before upload ?



It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

SamBrownADK

Windows Vista Pro.  Standard USB port and cable. I have been using it with no problems for weeks. Now, suddenly, can not up load the sketch.  I switched to the Blink sketch that comes with the IDE just to eliminate the possiblity maybe it was my code some how. Still can not up load.   Re-booted the desk top and tried to up load the Blink to a different Uno: worked perfect. just this one clone (eBay) Uno with a 328P-AU chip can no longer be uploaded to.

All my boards are identical clones bought from one vendor in china on eBay. Nothing was attached or removed from the board. So my set up is desktop ->  Genuine Arduino cable -> Uno (with nothing attached, not even an extra LED).

The board I can live without, their cheep.  I want to understand what / why this happened though.

Thank you.

SamBrownADK

ballscrewbob :


Screwballbob?   LOL   Do you actually LIVE in the object in your profile pic?  LOL 

ballscrewbob

Hi Sam...LOL No I dont live there but I took that pic on a big European tour and loved it.

Does it pass a loopback test (see top of forum post).

You could also try to re-bootload (Google "arduino as isp") it from one of the others that are fine to see if that resurrects it.

Any accidents  ya know like stray wires or voltages that might have let the magic smoke out of it ?

As you say clones are cheap enough but yes its always good to do a post mortem to avoid similar things in future.


It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

SamBrownADK

Loop test does not work.

Does not work with "Arduino as ISP" either.

No mechanical accidents / interfearances. No stray wires.



I will try to re-burn the boot

Go Up