Go Down

Topic: Compile error  (Read 861 times) previous topic - next topic

Voel

checked the sketchbook location and installed all the libraries in there and I ended up with the same problem as where I started this topic with. Also copied the files  LedControl.h and LedControl.cpp one level up. But this is not working.....

pert

Try this:
  • Sketch > Include Library > Manage Libraries
  • Wait for download to finish
  • In the "Filter your search..." box, type "ledcontrol"
  • Click on the LedControl entry
  • Click "Install"
  • Wait for installation to finish
  • Click "Close"
  • Try compiling your sketch again.

Voel

I have followed your instructions. Installed a new version of LedControl. Problems are same as when I started this topic.

pert

I'm stumped. It's the first time I've seen something like this in years. You could try changing your sketchbook location to a location outside of C:\Users\FLiGH  HiGH\Documents via the File > Preferences > Sketchbook location. I never trust these special Windows folders.

Other than that you could go back to using the libraries folder of the Arduino IDE installation folder but just keep in mind that you will need to either copy all of your own libraries out of there before updating or install them all over again every time. It's not such a big deal as long as you know it's going to happen and be very careful not to lose your only copy of any custom libraries you have written/modified.

Voel

Thank you all for putting me in the right direction. I pointed wrong to the sketchfile, I adressed the directory without a slash (\). Added the slash and the compiling error was gone!


 :)  :)  :)  SOLVED

Go Up