Pages: [1]   Go Down
Author Topic: RFID issue  (Read 618 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 1
Posts: 8
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I've been trying to get an RFID reader to read an RFID card with the past while yet to no avail. I'm pretty certain that I have everything connected properly on the breadboard and to the RFID reader and Arduino board.

Here is the spec for the Reader... http://www.coolcomponents.co.uk/catalog/product_info.php?products_id=504

I'm getting the following error when I upload from the Arduino software to the board... 'Problem uploading to Board'. I'm just getting the follwing output:

Binary Sketch size: 5632 bytes (of a 14336 byte maximum)
avrdude: stk500_getsync(): not in sync: reap=0x30
avrdude: stk500_disable(): protocol error, expect=0x14, reap=0x51

I've downloaded and copied & pasted the 'NewSoftSerial' library into the Arduino Library folder and then imported that sketch into Arduino... where I've also copied the test code from http://www.coolcomponents.co.uk/catalog/resources/RFID1356/RFID1356_Test.pde into the Arduino sketch.

If anyone has any solution to the problem I would appreciate it greatly. Sorry if the description above is a little vague... but I'm afraid I'm not much of an electronics or coding expert smiley-sad
Logged

California
Offline Offline
Full Member
***
Karma: 0
Posts: 129
That's me, the boy with the broken halo.
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I don't know about your unit, but when I use my RFID unit I have to unplug the antenna, upload the sketch and then plug the antenna back in to get the sketch to run correctly.  Might be worth a try.
Logged

0
Offline Offline
Newbie
*
Karma: 1
Posts: 8
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I don't know about your unit, but when I use my RFID unit I have to unplug the antenna, upload the sketch and then plug the antenna back in to get the sketch to run correctly.  Might be worth a try.

Cheers for the reply. Still no joy though, unfortunately.
Logged

Manchester (England England)
Offline Offline
Brattain Member
*****
Karma: 604
Posts: 33448
Solder is electric glue
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

You might have more basic problem with your arduino. Remove the RFID and just try and upload the LED blink sketch.
Logged

0
Offline Offline
Newbie
*
Karma: 1
Posts: 8
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I tried the LED blink sketch and it works fine.

I should also add that since the original post the sketch is now uploading to the i/o without any problems. But I'm still confused as to why I can't get any readings from the rfid card. I also received some rfid tags this morning so it would be great to crack on and get some communication going between them and the arduino.

Could anyone recommend a basic sketch to get a test reading from the rfid card or tags? Much appreciated.
Logged

Pages: [1]   Go Up
Jump to: