Go Down

Topic: Bootloader unable to program FLASH (i.e. upload sketch)? (Read 3 times) previous topic - next topic

chrissv


I assume from your lack of reply that the answer is no.


Sorry, I'm not ignoring your request. I had some other personal matters jump to the forefront, but I have bookmarked this request and am still planning on responding.

Checkers1811

Thanks. No problem.
I have tried several times to recompile the bootloaders that come with the Arduino development system and every time I get this message that it won't fit into the 644. When I compare the HEX files from the one that is in the Arduino folder with the 'same' one which is simply re-compiled, I find that it really is larger and overflows the top of memory. So I am striking out in most respects. One would think it was an easy task to compile a boot loader.

Hoping that yours will work 'as-is' so that I don't have to try to compile it.


westfw

Quote
every time I get this message that it won't fit into the 644.

Did you get this patch: http://code.google.com/p/optiboot/issues/detail?id=1&can=1

Checkers1811

Thanks, that does put me one step closer.
The bootloader now fits, but it is still not responding. I have tried to send commands over the serial monitor at various baud rates, but there is nothing coming back.
still waiting on chrissv to respond with a working version. I hope it is soon.

Checkers1811

I have made some progress with this and have but one thing to overcome.
I have a bootloader that works once. I program it into a new part with all other program space erased (oxFF). Then I use the Auduino IDE to load a sketch and it does just great; loads it up and verifies and runs.
The second time that I try to upload a sketch the bootloader no longer respoonds. I see that it hesitates for a moment, then it continues to run the previous sketch. I can see that the reset line is pulled low (volt meter) and the IDE is waiting for a response from the micro that it never gets. It times out after about 30 seconds.

So, what do I look for next? I am using the same Sanguino bootloader that was mentioned at the beginning of this thread, but it is adjusted for 8Mhz. I would have thought that there was nothing else to do but get it to work at the new clock speed.


Go Up