Pages: [1]   Go Down
Author Topic: OSX issue with Duemilanove  (Read 1980 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 12
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi, I have an issue. My cosmo black star (russian version of Duemilanove) works fine on windows but avrdude keep telling me this "avrdude: stk500_recv(): programmer is not responding"
I think it have something to do with the ftdi driver but I took the last version from the website, I tryed the version within the .dmg. nothing works smiley-sad

Anyone have an idea?

Thank you.

PS: It worked fine with my Uno. I changed the board type and I checked the serial port selection.
« Last Edit: February 09, 2011, 02:28:10 pm by creack » Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 5
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I had the exact same issue with my DIY Duemilanove and resolved it. The board has a resistor named R2 with a value "100_NM" - see the schematic. "NM" stands for "Not Mounted", but Cosmo Black Star appears to have in soldered to the board, at least it is there on the photos at jt5.ru. This resistor connects RTS# pin of FT232RL with the RESET pin of the ATMega. This has no effect under Windows, but Mac OS X seems to force RTS low while the serial port is in use. That is, whenever you are trying to upload a sketch from the IDE, the ATmega is in reset, and avrdude correctly reports that "programmer is not responding". I removed R2 from the board, and now it works fine in both Windows and Mac OS X.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 12
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thank you for your reply, but I am kinda not in the mood of unsolder something on the board right now ^^. If I don't find an other solution, I'll stay on windows.

I made some experiment and I tried to upload through the serial port.

I succeded once. I don't know why or how. I had a lot of wire everywhere and maybe it has touch something? I don't know. Anyway, as I succeded once, I guess there is something special I should do.

So what do I need to do in order to upload with the serial port?

Thank you,
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 5
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Don't worry about desoldering. R2 should not be there; look, for example, at the photo of the official Duemilanove at http://arduino.cc/en/Main/ArduinoBoardDuemilanove. The resistor is a small 0805, just touch it with a soldering iron, and it will get loose.

If you insist you don't want to touch it, you can use the serial port without the onboard FT232, but then you will need to manually reset the board (push the button) at the exact time when avrdude starts looking for the bootloader. Pressing reset makes the board execute the bootloader, which looks for avrdude on the other side of the serial port. If there is no avrdude there, it transfers control to whatever sketch has been uploaded. You will have to experiment with the timing of manual reset. This is a workaround; desoldering R2 is much easier and is the correct way to make the board work.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 12
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I finally unsolder R2 and it indeed worked fine smiley

Thank you a lot.
Logged

Pages: [1]   Go Up
Jump to: