Go Down

Topic: Upload frustration (Read 2709 times) previous topic - next topic

cyberbot

I seem to have a very typical problem with the Arduino, failure to upload a sketch.  Very very frustrating.

Binary sketch size: 1018 bytes (of a 32256 byte maximum)
avrdude: stk500_getsync(): not in sync: resp=0x30
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

It is a brand new Arduino Uno SMD and this is the first sketch I have tried to upload.  It has never worked.  The board and serial port are set properly under the tools menu in the IDE.

I have tried this and get the same errors on two different systems, one a Win 7 and the other a Win Vista system (64bit),  version 0022 of the IDE in both cases.

I have tried the hack of pressing the reset button at various times before during and after an upload attempt.  No go.

I have tried all of the COM ports from 3 to 10, and updated the device drivers at least twice, removed the driver completely and reinstalled it twice.
I have tried two different USB cables, and all of the various usb ports on my computer -no hubs.
I have gone through all of the troubleshooting tips on the installation page-  no go.  I have read dozens of posts and tried the various tecnhiques.   I don't have an LED for pin 13, so I have not tried that.

The power LED (green) is on the UNO.
The little yellow LED normally flashes about twice a second.
TX and RX blink when I try an upload.

Serial .verbose is set to true in preferences, but I see nothing from this

Is there any real solution?

cyberbot

#1
Feb 11, 2011, 06:48 am Last Edit: Feb 11, 2011, 07:38 am by cyberbot Reason: 1
Just as an update I tried my Uno on a Windows Xp machine, following the instructions to the letter, but I get the same exact error on that system as well.  I tried com3, where it first installed, and again on com5.

I turned off my Firewall, no luck.

I tried changing the baud rate on the driver - 4800, 9600, 115200... no luck.

I guess I will just wait for my external power plug to arrive and try that.

mellis

It's weird that both RX and TX flash but it doesn't work.  Can you post the verbose output that you get when uploading?  (Hold down shift while pressing the upload button in the toolbar in the Arduino software.)  It might give us an idea of what's happening.  Do you see the Arduino in the Device Manager?  You'll want to use the COM port it's listed as having there (trying other ones won't help). 

cyberbot

In talking with the support people at Adafruit, it appears that there is an issue with the board itself.  The TX light flashes, but no data is going out - so the IDE is getting no response - hence the problem.

Adafruit is sending a replacement board.  Two thumbs up for the team at Adafruit.  They responded quickly and were quite helpful.

This is what I was seeing with the Shift->Upload command:

Binary sketch size: 1018 bytes (of a 32256 byte maximum)
D:\Stephens\arduino-0022\hardware/tools/avr/bin/avrdude -CD:\Stephens\arduino-0022\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -cstk500v1 -P\\.\COM5 -b115200 -D -Uflash:w:C:\Temp\build6392328306294184287.tmp\Blink.cpp.hex:i

avrdude: Version 5.4-arduino, compiled on Oct 11 2007 at 19:12:32
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         System wide configuration file is "D:\Stephens\arduino-0022\hardware/tools/avr/etc/avrdude.conf"

         Using Port            : \\.\COM5
         Using Programmer      : stk500v1
         Overriding Baud Rate  : 115200
avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x30
avrdude: Send: Q [51]   [20]
avrdude: Recv:
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done.  Thank you.


Oniks

#4
Feb 13, 2011, 03:34 pm Last Edit: Feb 13, 2011, 04:17 pm by Oniks Reason: 1
I am also have this problem.And same output.Please help.
Binary sketch size: 1018 bytes (of a 32256 byte maximum)
F:\arduino-0022\arduino-0022\hardware/tools/avr/bin/avrdude -CF:\arduino-0022\arduino-0022\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -cstk500v1 -P\\.\COM1 -b115200 -D -Uflash:w:C:\Users\AACE~1\AppData\Local\Temp\build6128038875623077218.tmp\sketch_feb13a.cpp.hex:i

avrdude: Version 5.4-arduino, compiled on Oct 11 2007 at 19:12:32
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         System wide configuration file is "F:\arduino-0022\arduino-0022\hardware/tools/avr/etc/avrdude.conf"

         Using Port            : \\.\COM1
         Using Programmer      : stk500v1
         Overriding Baud Rate  : 115200
avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: Send: Q [51]   [20]
avrdude: Recv:
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done.  Thank you.

mellis

Oniks: did you get the drivers installed correctly?  (If you go in Device Manager, the Arduino should be and should have a serial port assigned to it.)  Are you sure it's on COM1?

Oniks

mellis, sorry for noob question but where can i see tutorial about drivers installing?And yes, i am sure it's com1.



Go Up