Go Down

Topic: Prob with USB Host Shield with an Ethernet Shield (from old forum) (Read 4237 times) previous topic - next topic

GianfrancoPa

The old forum topic: http://arduino.cc/forum/index.php/topic,28744.msg212881.html#msg212881
---------------------

I tried using the Sparkfun USB HOST SHIELD and the Arduino official Ethernet shield together. They came into conflict!

So, in order to not modify one of two shieldd, I did the following:
I connected the USB host shield to the Ethernet shield using some headers, I took the 10-pin header and put it out, then I made a bridge between the pin 10 and the pin 6, and finally I changed (as Felis says to do), the SS pin in Max3421e_constants.h file from 10 to 6.

Done, everything works fine without making any changes to any of the shields!




Gianfranco

ehvie

Hello, I have a similar problem with Due + USB Host shield + Ethernet shield:
They use both SS at pin 10, so I have moved it on USB Host Shield to pin 7, updated the UsbCore.h. too and verified if working.
Moved then INT from 9 to 6, updated UsbCore.h and works.
... but it works, also when the wire between INT and P6 is disconnected!!!

Second problem is, that the Ethernet really works perfectly, but until Usb.Init() is called to initialize the USB Host library.

Don't you have similar experience?
Can't it be connected to the INT issue?

ehvie

Seems I have solved the problem:
Before ethernet initialization it is necessary specifically require SPI for Ethernet shield.

    pinMode(10,OUTPUT);
    digitalWrite(10,LOW);

Did the trick.

Go Up