Go Down

Topic: Arduino on Debian box - suddenly unable to upload sketch to Uno. (Read 7914 times) previous topic - next topic

with the help of forum's users I've updated the firmware in a few minutes without any pain ;)
look at comment #4 @ http://arduino.cc/forum/index.php/topic,52447.0.html
--
MementoMori

Oh no,, it's all gone horribly wrong. I followed these instructions

http://arduino.cc/forum/index.php/topic,52447.0.html

very carefully up to the point

UPLOAD THE NEW FIRMWARE (console commands)

The first upload instruction responded with

dfu-programmer: no device present.

which doesn't look good. Am I being stupid? The UNO was plugged in with the little TX light glowing.

I then tried to verify a simple sketch from the IDE. I got  an eror: Cannot run program "avr-gcc" .... NO such file or directory. From this I deduced that my IDE had gone west, so I decided to reinstall it, starting with arduino-core. I went to Synaptic and searched for arduino packages - zilch. I have Lenny installed but there are no arduino packages available, apparently (I checked on the Debian website).

So now what, step by step, do I need to do to restore the situation? The Linux installation instructions on the Arduino website are confusing me.

TIA




mrtaylor

Quote
dfu-programmer: no device present.

I get same error if the atmega8u2 chip is not in DFU mode

my Uno not in DFU mode:
sudo dfu-programmer at90usb82 erase
[sudo] password for mark:
dfu-programmer: no device present.

Uno in DFU mode. There no output if the command works
sudo dfu-programmer at90usb82 erase





if you have the TX led "always on" when you plug the board to your linux box you should first upload an "empty sketch" into the board. I've used something like:

Code: [Select]

void setup(){}
void loop(){}


but since you cannot upload sketches from your linux box (because of this bug!)  you have to do that from a windows os (mac not tested).
--
MementoMori

Go Up