Pages: [1]   Go Down
Author Topic: [SOLVED] Arduino <-> APC220 Wireless and RealBasic + APC220  (Read 2024 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 2
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi all, im pretty new in these forums but not with RealBasic.

Im trying to use realbasic language to talk to the APC220 Wireless module directly.
The APC220 Can talk very easy using the APC220 plugged with USB to serial converter trough the Arduino Serial Monitor.

Settings in Arduino Serial monitor: (Setup: LAPTOP + APC220/usb  and APC220 + Arduino UNO)
I have selected the baud rate 19200 (wich has been set in both APC220 modules), the Carriage Return is selected and send a message "on" or "off" to turn the light on or off on Pin 13.

In this way it works perfectly, but now it comes when i try to do this trough my realbasic application there is nothing send (or..?).
I have received some info in the buffers when i had a script on the arduino wich sends "A" every x ms, this worked for receiving.
But when i try to send from my Realbasic app to the APC220 Wireless module wich need to send it to the Arduino it doesnt work.

Im using Stop bits 1, Bits 8, Baud 19200 (on overything), Parity none. I send the string "on" + Chr(13) wich sends "on" with a Carriage Return.(like the Arduino IDE Serial Monitor does).

Can someone tell me if i need to send strings in some special encoding?
And or if the settings are correct?
When i use to send directly with Arduino USB cable, everything suddenly works.. I cant seem to send it trough the APC220 Wireless Module's usb/serial converter. What am i doing wrong here that Arduino IDE Serial Monitor does right?

Thanks ALL!!

[solved] ive solved this problem by using the usb-b (square) rx/tx uart board, the ones that come with APC220 could not work for some reason.
« Last Edit: March 06, 2011, 10:45:42 pm by produino » Logged

Pages: [1]   Go Up
Jump to: