Go Down

Topic: USB support in Linux. (Read 1 time) previous topic - next topic

haughtonomous

I would like to see this made somewhat more robust.

I'm using a UNO with Debian Lenny (nothing bleeding edge there) with the 0022 IDE.  The IDE keeps 'losing' the ACM0 serial port, so I can't subsequently upload a sketch. The workaround seems to be to load an empty sketch (just an empty loop() and setup() function, nothing else), immediately before attempting to load my real sketch.

I also find that if I load a sketch form the Load button, it loads into the current IDE instance. However if I load the sketch using the File>Load menu item, a new IDE instance is launched for the loaded sketch. Thereafter it can't find the ACM0 port, reporting that it is already in use. My guess is that this is the first IDE instance grabbing it. The workaround is to close both IDE instances, start a new instance and load and then upload the empty sketch, then load and upload my real sketch using the load/upload buttons - and make a note to remember this in future (I keep forgetting!).  I would love this all to be fixed.

mellis


haughtonomous

Thanks, but I've tried that. I've tried putting mu Uno into DFU mode using all the methods suggested, without success. I always get the message which tells me it is not in DFU mode.

pluggy



Without this and an updated optiboot, I'd written off the Uno as unusable.
http://pluggy.is-a-geek.com/index.html

haughtonomous

Thanks, but that is exactly one of the methods I've tried. No change. My Uno stubbornly refuses to go into DFU mode this way.

pluggy

Come back FTDI, all is forgiven.....

http://pluggy.is-a-geek.com/index.html

stimmer

If you can't get it into DFU mode at all it sounds like it's an RMA.

Also, some of the Debian users said they needed to recompile the latest dfu-programmer from source as the one in the distribution was too old.
Due VGA library - http://arduino.cc/forum/index.php/topic,150517.0.html


pluggy

http://en.wikipedia.org/wiki/Return_merchandise_authorization
http://pluggy.is-a-geek.com/index.html

Terry King

RMA? DFU? How about the FAQ gets a GLOSSARY???
Regards, Terry King  ..On the Red Sea at KAUST.edu.sa
terry@yourduino.com  LEARN! DO! (Arduino Boards, Sensors, Parts @ http://yourduino.com

Go Up