Go Down

Topic: COM Port disappears after RESET. No Serial Communication. (Read 526 times) previous topic - next topic

ellokah

Dear Community,

I have some troubles with my Arduino MKR 1400 and hope you can help me:

When I upload a sketch, everything works just fine. I can see my Arduino in the Windows device manager (Win 7) connected to COM18, and both IDE and Web editor recognise it too at this Port. The code executes as expected, and in the Serial-Monitor I can listen to my Output (Let's say a simple blink sketch with some "ON","OFF" Serial output via USB).

Then, after a RESET (either by clicking one time the reset button, or using the watchdog timer), of course the code and Serial-communication stops. I can hear this windows sound for disconnecting USB devices, followed by the one for connecting an USB device. In the windows device manager my Arduino is still shown available on COM18, it never changed.

So far everything works as it should be. The problem is as follwes:

After restarts both the IDE and web editor stop to recognise the MKR on COM18, i.e. in the Tools>>Port Tab of IDE no longer COM18 exists. The blink sketch seems to restart as expected, so the arduino is still working, but I can't open the Serial Monitor to see the Serial-Output. He always tells me:

Quote
Board at COM18 is not available
Additionally, I can't upload a new (or even same) sketch in this condition. The console tells me after compiling:

Quote
Couldn't find a Board on the selected port. Check that you have the correct port selected.  If it is correct, try pressing the board's reset button after initiating the upload.
Indeed, I only can reupload a new sktech and hence, reestablish a Serial communication after pressing the RESET-button again.

However this is of course a little bit inconvenient, to upload a sktech for a complete restart of the arduino, as I'm depending on the Serial-Output for debugging. Also I can't check my Watchdog-Timer routines to work properly this way.

Does anyone of you could point me, what I'm missing here, or where I have to search the error?

Thank you for your help in adavnce,


Oliver

Go Up