Go Down

Topic: avrdude: stk500_getsync(): not in sync: resp=0x0d on a mac (Read 3224 times) previous topic - next topic


I am confused.  A couple weeks ago I got an arduino pro 328 and the gps shield.  I am using arduino 0022.  It worked fine but the GPSr was defective.  I got the new module and now I get
avrdude: stk500_getsync(): not in sync: resp=0x0d
avrdude: stk500_recv(): programmer is not responding

I booted to windows and it works fine there.  Why would it fail in windows?


"pro 328" and "new module" aren't official Arduinos.  Can you please elaborate on what you are using?
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com



"new module" is new GPS module to replace the defective unit.  I bought the GPS shield and EM-406 GPS module form sparkfun.  The antenna wasn't working on the module I received.  The module was communicating with the arduino over serial but not getting a fix.  After talking to sparkfun support we found it was a defective GPS module.  So I had it replace.  I didn't change the code or install any new libraries for the Arduino. 

Obviously it worked on my Mac before I sent in the defective unit.  After hooking up the new unit I got that error.  I booted to the Windows side of my Mac and also using arduino 0022 it worked fine.  So it isn't the FTDI cable and it probably isn't the hardware.  Somehow the software changed.

I tried uninstalling the arduino software and removing any third party libraries I had.  I then reinstalled the arduino software and tried the basic blink led sketch.  I still got the error.


It is not clear which combination of hardware and operating system gave which results.  Forget about the GPS for a moment and use a simple sketch such as the one that blinks the built in LED and see if you still get the error.

The error messages indicate a failure in communication between your computer and your Arduino.  It has only come up about a billion times in the last month or so.  Have you done a search (use the box in the upper right corner) for either of the error messages.  Don't forget to try the old forum.

You may be having a conflict between the serial link to the shield and the serial link to your computer.  You should make sure that the GPS shield is not using pins 0 and 1.



Yes, I tried doing just a simple sketch.  Like I said, I uninstalled the arduino software and all extra libraries (in the documents fold on both mac and windows).  I then just tried the blink led sketch, on both windows and mac.  It uploads fine on windows, but on the mac side I get the error.

The GPS shield is not using pins 0 and 1 when it is on the arudino as I can upload fine on windows.

Yes, I did search.  But as you said it has come up a lot lately so there are a lot of searched to sift through.  None of what I read seems to be the appropriate answer.  Most are saying the cable/ftdi connection is bad or the wrong board was selected.  If either of those were the case it wouldn't work on the windows side.

So, the conclusion then is somehow the Mac side has decided to not like the FTDI cable anymore.  I have an RBBB arduino on the way, I will have to try with that when I get it.  I have this cable: http://www.sparkfun.com/products/9718

I did notice when double checking the board to select in the software the two Arduino Pro entries are the same description.  They both say the 128 version.  No 328 version listed.  I tried all possible 328 boards.  As I said, it worked a couple weeks ago but not now.  I don't remember what board was selected a couple weeks ago.


Alright, I got the RBBB.  Same exact issue.  This means that somehow the Mac side is rejecting my FTDI cable.


You could try installing the latest FTDI Mac drivers from http://www.ftdichip.com/Drivers/VCP.htm.  Do you have the right board selected from the Tools > Board menu on the Mac?  What about the serial port? 

Go Up