Go Down

Topic: ESP8266 has red led but not active after flashing (Read 316 times) previous topic - next topic

beshur

Hi Guys.

I've been tinkering with ESP8266 for a couple of weeks now. It worked before the weekend, and now with only some code changes it stopped (but it does not seem to crash).

My project: Tabletop clock with weather. For now I'm trying to get weather from openweather API via ESP8266. I actually managed to do the request, and now was trying to parse JSON, and at this point it stopped working.

My setup: USB CP2104 CP2102 - UART TTL flashing stick Arduino Uno - only provides power to ESP (see below), RX/TX not connected.

ESP8266 CH_PD and VCC powered from Arduino Uno 3.3V pin GPIO2 is connected to GND. The rest of pins are connected to the flashing stick.

Problem: 1. I run flashing from Arduino IDE. 2. Compilation is ok, uploading is ok on 115200 baud, serial monitor is also 115200. 3. Sketch uploading progress is visible in IDE terminal, blue LED on ESP is rapidly blinking while uploading. 4. After upload is finished, I see something like "tail 8, checksum ... " in the serial monitor.

Then I do not see anything in serial monitor. The red LED on ESP is very weak after flashing - the last time I tried to flash it - it is not visible with the lights on. The ESP does not connect to router (according to router info).

Also one strange sideeffect - after flashing, wi-fi drops on my laptop.

What may be the issue? Thanks.

Juraj

3.3 V 50 mA max pin Arduino Uno can't provide necessary power for the esp8266
You can't write an Arduino sketch if you didn't learn programming. Not the language, but the concepts of programming - algorithms and data types.

PieterP

pin GPIO2 is connected to GND.
Where did you get that idea?

You didn't post any code, and you are paraphrasing the debug messages from the ESP. How are we supposed to say anything useful?

Pieter

Go Up