Pages: [1]   Go Down
Author Topic: 1-wire  (Read 1433 times)
0 Members and 1 Guest are viewing this topic.
Toulouse, France
Offline Offline
Newbie
*
Karma: 0
Posts: 8
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

bonjour,

j'ai une petite installation domotique à base de composants 1-wire, d'un arduino, et de cable CAT5-FTP :
- DS2406 (mode parasite & mode alimenté)
- DS18B20 (mode alimente)

Je suis confronté a un probleme :
lorsque que je branche sur mon reseau 1-wire un DS2406 avec plus de 10m de cable tout le reseau 1-wire est perturbé. Plus aucun composants n'est visible depuis l'arduino (lib OneWire).

qq'un a-t-il deja eu ce genre de soucis ?
j'ai lu qqpart que le cable reseau CAT5 blindé causait qq problemes, est-ce vraiment le cas ? dois-je recabler en CAT5 UTP ?

petit detail : les sondes de temperatures DS18B20 ne posent elles aucun soucis meme si elle sont au bout de plus de 10m de cable.

test ultime fait :
- 1 arduino + 1 cable de 15m + un DS2406 ---> pb
- 1 arduino + 1 cable de 5m + un DS2406 ---> OK

merci par avance pour votre aide.
Logged

Celtic Kingdom
Offline Offline
Sr. Member
****
Karma: 2
Posts: 455
hard oui no!!!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Salut luccio,

Il y a une solution pour l'utilisation longue distance avec le DS18B20 ici :
-> http://www.maxim-ic.com/app-notes/index.mvp/id/148

Cela fonctionne jusqu'à 200m avec un MOSFET 2N7000.
Voir ajuster la résistance de pulldown..
Logged

Toulouse, France
Offline Offline
Newbie
*
Karma: 0
Posts: 8
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

oui j'ai lu cette doc.

le pb c'est que chez moi je n'ai pas de soucis avec les sondes DS18B20, sur 15m de cables elles fonctionnent bien.
mais ce sont avec les DS2406 que ca se gate au dela de 10m seulement ...

Logged

Celtic Kingdom
Offline Offline
Sr. Member
****
Karma: 2
Posts: 455
hard oui no!!!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ils sont alimentés sous quelle tension les DS2406 ?
Car il semble avoir une doc' à propos de "3.5V" +/- "je ne sais plus quoi" pour une question de rapport signal/bruit...
Si je retrouve je te donne ça.
Logged

Toulouse, France
Offline Offline
Newbie
*
Karma: 0
Posts: 8
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ils sont sous 5V (pour ceux qui ne sont pas en mode parasite).
3.5v ? effectivement je ne respecte pas ca... ta doc m'interesse oui ! merci



Logged

Celtic Kingdom
Offline Offline
Sr. Member
****
Karma: 2
Posts: 455
hard oui no!!!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

J'ai remis la main dessus :
-> http://www.midondesign.com/Documents/PARAPWR2.PDF

En espèrent que cela puisse aider...
Logged

Toulouse, France
Offline Offline
Newbie
*
Karma: 0
Posts: 8
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ok merci je vais y jeter un oeil
Logged

Pages: [1]   Go Up
Jump to: