Go Down

Topic: error: espcomm_upload_mem failed ESP8266 ERROR (Read 2738 times) previous topic - next topic

Hi! I recently bought my first esp module for my Arduino, i bought this module: Esp8266



I connected the Esp8266 in the following way :



When i run the code i get the following error:

   
Code: [Select]
error: failed reading byte
    warning: espcomm_send_command: can't receive slip payload data
    error: failed reading byte
    warning: espcomm_send_command: can't receive slip payload data
    warning: espcomm_sync failed
    error: espcomm_open failed
    error: espcomm_upload_mem failed


i dont know what to do, please help!

Thanks in advance!

ieee488


ieee488


pert

Also posted at:
https://electronics.stackexchange.com/q/363251
If you're going to do that then please be considerate enough to add links to the other places you cross posted. This will let us avoid wasting time due to duplicate effort and also help others who have the same questions and find your post to discover all the relevant information. When you post links please always use the chain links icon on the toolbar to make them clickable.


I recommend the circuit in this article. https://www.allaboutcircuits.com/projects/flashing-the-ESP-01-firmware-to-SDK-v2.0.0-is-easier-now/. I have used it and it works for flashing the ESP-01.




I'll give it a try later, anyways i think that the error will continue. Thanks!

Juraj

why do you have RX from Uno on voltage divider? you need to reduce the voltage of transmit from Uno.

swap wires of RX/TX on Uno side, because you have TX to TX and RX to RX connected between uno and esp
You can't write an Arduino sketch if you didn't learn programming. Not the language, but the concepts of programming - algorithms and data types.

PatrickW

Hey imtdb,

I´m definitely not an expert on this topic,
but I´m currently working on a wireless connection as well.

Thank´s to this forum I bought a different board because I had the same error message.
I used the ESP 8266-01 as well and now I use a NodeMcu board
https://www.amazon.de/gp/product/B01GCK3J40/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1
I still have some issues as well, but at least I could do a Wifi scan already
what I could not even do with the ESP 01 module. :/

At least no more error messages so far :)

Hope I could help a bit.

Greetings from Upper Bavaria
Patrick

ieee488

#8
Mar 27, 2018, 06:22 pm Last Edit: Mar 27, 2018, 06:23 pm by ieee488
Hey imtdb,

I´m definitely not an expert on this topic,
but I´m currently working on a wireless connection as well.

Thank´s to this forum I bought a different board because I had the same error message.
I used the ESP 8266-01 as well and now I use a NodeMcu board
https://www.amazon.de/gp/product/B01GCK3J40/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1
I still have some issues as well, but at least I could do a Wifi scan already
what I could not even do with the ESP 01 module. :/

At least no more error messages so far :)

Hope I could help a bit.

Greetings from Upper Bavaria
Patrick
You made a good choice with the NodeMCU board.

ESP-01 to Arduino is not beginner-friendly.

Here's a list of the modules I would have bought if knew then what I know now.  :)

https://www.losant.com/blog/top-6-esp8266-modules


.

Go Up