Go Down

Topic: Arduino Environment won't install / run (Read 1 time) previous topic - next topic


Hi again,

I'm having a problem getting started it seems. I've downloaded the Arduino environment, unzipped it, and launched arduino.exe, but after a few seconds I get an error message saying "An error occurred while starting the application." In addition, I have a Java process sitting in my task bar.

Any ideas? I'm willing to bet Java is not installed correctly on my machine, but I'm hoping someone can confirm this.


What version of Windows are you running?

The Arduino software comes with Java, but you can try deleting that one and it should try to use a system-wide one (if you have one installed). 

Are you sure it downloaded and unzipped properly?


Sorry, I was meaning to put that info in the original post, but I was rushing to bed. :P

I'm running Windows 7.

I actually tried downloading the ZIP file a second time as I was a lil suspicious something was not right when the ZIP file took AGES to unzip. Something like 20 minutes! I downloaded the ZIP a second time, and the same thing happened. Finally unzipped, ran the EXE, and same error message.

I'll wip Java off the machine tonight (at work now), and put it back on. Hopefully that fixes it.


Feb 28, 2011, 08:49 am Last Edit: Feb 28, 2011, 08:51 am by nick Reason: 1
Windows 7 does take a ridiculously long time to unzip Arduino. 7zip is free and much, much quicker. You can download 7zip over a slow internet connection install it and use it to unzip Arduino faster than Windows will unzip it.

I have seen errors from the process failing on machines that are taking so long, so maybe try using 7zip and see if that solves your problem.



Feb 28, 2011, 10:24 am Last Edit: Feb 28, 2011, 10:26 am by Griff Reason: 1
I already have 7zip, so I will give that a whirl right now!

It's unzipping MUCH faster...

Damnit, still no dice, though I have a different error message now: "An error occurred while starting the application. Invalid window handle."

I tried launching the EXE again, and I got the old error message. Odd...


My friend just advised of this page: http://www.java.com/en/download/faq/java_win64bit.xml

I should have mentioned I am using 64 bit, Windows 7.

So hopefully this solves the problem.

Go Up