Go Down

Topic: wavgat problems... (Read 7132 times) previous topic - next topic

joemon

after ive figure out about the troubleshooting again another problem occured

Arduino: 1.8.5 (Windows 7), Board: "WAVGAT UNO R3"

C:\Users\cam\Documents\Arduino\hardware\WAV\avr\cores\lgt8f\Print.cpp: In member function 'size_t Print::print(const __FlashStringHelper*)':

C:\Users\cam\Documents\Arduino\hardware\WAV\avr\cores\lgt8f\Print.cpp:44:23: warning: '__progmem__' attribute ignored [-Wattributes]

   const char PROGMEM *p = (const char PROGMEM *)ifsh;

                       ^

avr-gcc: error: C:\Users\cam\AppData\Local\Temp\arduino_build_791809/core\core.a: No such file or directory

exit status 1
Error compiling for board WAVGAT UNO R3.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

lagedor

Thanks thanks thanks!
.
.
.


I also had the same issue at first but I have found the solution...

Step 1
----
Download the following RAR file from the link below;
https://drive.google.com/open?id=10gwrG9uTDwaEO-7EudsmBkfgdcyrcABI

Step 2
---
Once downloaded, extract these and copy the content within the "update" folder (not the "update" folder itself just the content inside it)

Step 3
---
Paste content to the following path on your computer...
C:\Users\Administrator\Documents\Arduino

Step 4
---
Restart Arduino IDE Software

Open Arduino IDE, select your COM port if required and Select your WAVGAT board type (WAVGAT boards are at the very bottom of the board list)

Enjoy!


Hope this helps

W.

122402902

You need install the CH340 driver after upload

bookaroo

Hi, I have tried to use the arduino package from the google drive link, but some functions do not work, like serial print of a floating point variable.

My board as one 12Mhz crystal near the USB chip and a 16MHz near the microntroler chip.

I have looked in the board.txt that came with the package and it list the chip used as an LGT8FX8P even if on the chip itself it is written Atmel Atmega328P.

So I search for that chip and found an github project for arduino similar to the one from the aliexpress link, called LAdruino_HST https://github.com/LGTMCU/Larduino_HSP

This one works great with the latest Arduino, no warning, you have to select LGT8F328P-LQFP32 MiniEVB as an arduino board after the install.

You may have to delete the files from the other package before installing this one, in my case it was warning about files in double so I did...

Hope it helps some body.


Thank you.

AingeruJM

Hi bookaroo,


please, could you upload some pictura of the actual board?

Did you have to change or upload the bootloader?

Could you indicate a step-by-step list?

Thank you very much.

Go Up