Go Down

Topic: LED and aquarium controller with TFT LCD touch screen (Read 24319 times) previous topic - next topic

sundance2013

Due to the lack of much on the market normal people can afford I want to build a controller
for my 80G reef aquarium. I have never done a Arduino project before so I am the newest of
new beginners. This looks like a good project to start with but it's a bit unorganized (maybe just me
not knowing what I am looking at yet). I don't see any kind of parts list and schematic of this controller,
is there one? Also some of the links don't seem to work.

Should I look for a simpler project for my first? I have a basic electronics understanding but know
programming experience.

Thanks :)

cyclegadget

Quote

Should I look for a simpler project for my first?


If you want to understand how it all works, yes you should start with a simpler project. Otherwise, you need a kit put together for you. An aquarium controller contains several simple projects put together. You will be able to make it your own if you understand how it works.

I think you will enjoy the process. I recommend starting with the LEDs and work from there.

Good luck!
Good links: Eagle tutorial= http://www.youtube.com/playlist?list=PLDE1858BD83D19C70
General Arduion tutorials = http://tronixstuff.wordpress.com
http://www.gammon.com.au/forum/bbshowpost.php?bbtopic_id=123

amor

I'm trying to build this project everything works okay except the LED
They work upside when it is in 100% LEDs are switched off and when it is in 0% the LEDs in full power

voltesep

hi all,

could you help out a VERY newbie to the arduino side of things, tried to compile stilo 3.0
and got 104 errors??

tried various ide builds from 1.5.4 all the way back to 1.0 all resulted in the same 
cant be anything to do with the mega as im only verifying

tried a couple of the utft examples which compile and run ok, so looking to you guys for a heads up
got 3 arduinos one for the tank controller and the others for me to learn on

hope you can help??

RpNec

I would ask someone who would be able to help...
I built a controller (Stillo 3.0, thanks for share this) according to the instructions (i use 3 LED channels +moonlight) and everything seems to work perfectly except for one small thing and that is the moonlight part of code.
The problem is that whatever i set the LED conected to moonlight channel do still the same - it never turn off or reduce power according to the settings. (Weird) It is same in both real time and standard mode.
I already tried set moonlight to another pin and it is still the same.
But when i change that pin to classic dimmed (PWM) channel (lets say channel 4) then it is steered completely without problems. Does anyone have the same problem? Or have someone idea what can cause this?

Barclay

Hi, I tried this sketch, but the result is in the image file, why?



Go Up