Pages: [1]   Go Down
Author Topic: ArduinoISP , avrdude picks up the arduino’s MCU rather than my mega32 !!!  (Read 315 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I want to program my ATMEGA32A via Arduino as ISP :
1-program my Nano with arduino as ISP sketch
2-wiring like this (powering my mega32 with a voltage regulator)

                                                     

3- avrdude -P com2 -b 56700 -c avrisp -p m32 -v -e -U flash:w:myfile.hex

4-unfortunately avrdude shows me this message :
               

0x1e950f --> atmega328 (my Nano MCU)

0x1e9502--> atmega32 (my target MCU)

Looks like avrdude picks up the arduino’s MCU rather than my mega32 , after run the command with -F , avrdude programmed my poor nano . what is the problem ?
Logged

SF Bay Area (USA)
Online Online
Tesla Member
***
Karma: 134
Posts: 6760
Strongly opinionated, but not official!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Disable autoreset on your nano.  A 10uF cap between RESET and GND is one way.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Disable autoreset on your nano.  A 10uF cap between RESET and GND is one way.

ty for answer but nothing happend , other ways ?

Logged

Global Moderator
Dallas
Online Online
Shannon Member
*****
Karma: 207
Posts: 12928
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

2-wiring like this (powering my mega32 with a voltage regulator)

Grounds connected?

Quote
3- avrdude -P com2 -b 56700 -c avrisp -p m32 -v -e -U flash:w:myfile.hex

Wrong baud rate.  Wrong programmer.

Code:
avrdude -P com2 -b 19200 -c stk500v1 -p m32 -v -e -U flash:w:myfile.hex
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

2-wiring like this (powering my mega32 with a voltage regulator)

Grounds connected?

Quote
3- avrdude -P com2 -b 56700 -c avrisp -p m32 -v -e -U flash:w:myfile.hex

Wrong baud rate.  Wrong programmer.

Code:
avrdude -P com2 -b 19200 -c stk500v1 -p m32 -v -e -U flash:w:myfile.hex


ty for answer , I went to terminal mode and entered “sck 1000″ at the prompt , entered e and then set the programmer back to normal by entering “sck 10″ http://www.evilmadscientist.com/2007/fixing-a-bad-frequency-fuse-bit-on-an-avr/ . after that it's working  .

Code:
avrdude -P com2 -b 19200 -c avrisp -p atmega32 -t

               

Code:
avrdude -P com2 -b 19200 -c avrisp -p atmega32 -e -U flash:w:myfile.hex

               
Logged

Pages: [1]   Go Up
Jump to: