Pages: [1]   Go Down
Author Topic: Arduino UNO USB not working  (Read 1402 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hey Guys,

So I've been using my arduino UNO for a while now, on my Windows 7 64bit machine with no problems. I've been doing tutorials and getting the hang of the programming. I started playing around with serial read and the USB seems to have stopped working. I get this error when trying to upload:

avrdude: stk500_getsync(): not in sync: resp=0x30
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

After trouble shooting and reading forums I have come to the conclusion that the chip need to be reprogrammed(I'll probably just buy a new one). When I plug the arduino in it does not show up in the device manager. I wont be able to get a replacement chip for a few weeks, but I don't want to wait that long. Any suggestions on what I could do. I am fairly new to this so I'm hoping I'm wrong about the chip and might be able to find another solution.

Thanks.

P.S. I have have tried the board with other computers with different OS's and different leads. 
Logged

Massachusetts, USA
Offline Offline
Tesla Member
***
Karma: 179
Posts: 8070
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

The UNO uses an ATmega processor for the USB-to-Serial converter.  From what I understand this chip sometimes looses programming???  There is a jumpering procedure to put the USB-to-Serial chip in "DFU" (Direct Firmware Update) mode and re-flash it.  Try a search for DFU.
Logged

Send Bitcoin tips to: 1L3CTDoTgrXNA5WyF77uWqt4gUdye9mezN
Send Litecoin tips to : LVtpaq6JgJAZwvnVq3ftVeHafWkcpmuR1e

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks for that I put it in dfu mode and reflashed with filp and now it's back to normal.

Cheers.
Logged

Pages: [1]   Go Up
Jump to: