Go Down

Topic: Arduino UNO USB not working (Read 2020 times) previous topic - next topic


Hey Guys,

So I've been using my arduino UNO for a while now, on my Windows 7 64bit machine with no problems. I've been doing tutorials and getting the hang of the programming. I started playing around with serial read and the USB seems to have stopped working. I get this error when trying to upload:

avrdude: stk500_getsync(): not in sync: resp=0x30
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

After trouble shooting and reading forums I have come to the conclusion that the chip need to be reprogrammed(I'll probably just buy a new one). When I plug the arduino in it does not show up in the device manager. I wont be able to get a replacement chip for a few weeks, but I don't want to wait that long. Any suggestions on what I could do. I am fairly new to this so I'm hoping I'm wrong about the chip and might be able to find another solution.


P.S. I have have tried the board with other computers with different OS's and different leads. 


The UNO uses an ATmega processor for the USB-to-Serial converter.  From what I understand this chip sometimes looses programming???  There is a jumpering procedure to put the USB-to-Serial chip in "DFU" (Direct Firmware Update) mode and re-flash it.  Try a search for DFU.
Send Bitcoin tips to: 1L3CTDoTgrXNA5WyF77uWqt4gUdye9mezN
Send Litecoin tips to : LVtpaq6JgJAZwvnVq3ftVeHafWkcpmuR1e


Thanks for that I put it in dfu mode and reflashed with filp and now it's back to normal.


Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131