Go Down

Topic: Driving Heavy Loads (Read 1 time) previous topic - next topic

Hi,
I'm working on a big, powerful robot. It is like a tank and has 6 continuous rotation servos. I want to drive all of them using my arduino mega (the new one). My only problem is that my robot barely moves when I power all 6 servos at once. I don't know how to get more power to it. I'm not too familiar with current, but I believe I need more of that (is this true?).

i'm using the regular 5v output to supply my motors that run on 5v. I am also using a 9v battery (actually 6 AAs) with one lead in ground and the other in Vin. I am using a sketch that I know for sure works.

Can anyone help me?
Thanks
-Dylan

RuggedCircuits

You definitely need more power. It is a bad idea to source power to "heavy loads" directly from your Arduino's 5V output. That tops out at about 500mA and 6 servos can easily draw more than that especially when stalled or working hard.

Use a separate 5V power supply and connect its ground to the Arduino ground, but try to have as little common wire as possible between the servos and the Arduino. Ideally, there will be 2 ground wires coming from the power supply, one to the Arduino and one to all the servos.

--
The Quick Shield: breakout all 28 pins to quick-connect terminals

Thanks! I'll try that. I'm going to RadioShack tomorrow, do they have 5v batteries and what's a good kind to get?

Thanks so much for your help!  :)

Also, can I use voltages larger than 5v?

zoomkat

You probably need to get a UBEC like below and appropriate batterys to supply it. Otherwise a large rechargable 6v battery might work for the servo power.

http://www.hobbypartz.com/ubube.html
http://www.hobbypartz.com/ub2liin.html
Google forum search: Use Google Advanced Search and use Http://forum.arduino.cc/index in the "site or domain:" box.

Out of stock.  =( Can you suggest anything else?

Go Up