Pages: [1]   Go Down
Author Topic: DS1307 super chaud!  (Read 1844 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonjour,
je débute et j'ai commencé un essai avec un module DS1307 (platine avec ses résistance, condos et puce).
Le hic, c'est que branché sur le +5v, la puce chauffe énormément mais fonctionne. Sur le +3v, comme prévu, elle est en veille.
Je voulais savoir si cela est normal chez vous.

Merci de votre aide!
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 34
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Comment l'as tu branché ?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

je me suis servi de ce tuto:
http://www.ladyada.net/wiki/tutorials/learn/breakoutplus/ds1307rtc.html
j'ai juste modifier la ligne
    Serial.begin(57600); par 9600 sinon ca écrit n'importe quoi.

Logged

Ales
Offline Offline
Faraday Member
**
Karma: 39
Posts: 3654
Do or DIY
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Si tu as fait comme eux (brancher direct sur 4 pins analogiques), as-tu bien noté leur remarque : "If you set analog pin 3 (digital 17) to an OUTPUT and HIGH and analog pin 2 (digital 16) to an OUTPUT and LOW you can power the RTC directly from the pins!"  qui n'apparaît pas dans le code ensuite.

Et si ça marque n'importe quoi à 57600 c'est peut-être que ton serial monitor est à 9600 lui ...
Logged


Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Je me suis mal exprimé B@tto.

Cela fonctionne correctement (une fois que j'ai mis à 9600bds), j'ai utilisé le schèma utilisant le +5 de la carte et non depuis une sortie ana.


Le truc, c'est que ca chauffe énormement (surtout le condo ceramique) et ce, meme en ne branchant que le + et le -.... Est ce normal? est ce un défaut du module?

Logged

Ales
Offline Offline
Faraday Member
**
Karma: 39
Posts: 3654
Do or DIY
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ca me semble pas du tout normal pour deux raisons : d'une part ça n'a aucune raison de chauffer, d'ailleurs la conso est tellement faible qu'une pile bouton suffit à tenir 10 ans ! Et d'autre part, j'ai un module similaire et ça ne chauffe pas du tout  smiley-lol

As-tu essayé sans la pile ? As-tu acheté le module tout fait ou bien l'as-tu monté toi-même ?
Logged


Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Je l'ai acheté tout fait. Le circuit à l'air propre. La pile est arrivée emballée. J'ai pas vu de mauvaise soudure.
Merci pour l'info en tous cas. Je vais voir avec le vendeur.
Logged

Pages: [1]   Go Up
Jump to: