Pages: [1]   Go Down
Author Topic: LCD display issues 16x2  (Read 638 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi guys,

recently taken up the challenge of getting an LCD output working as I found a 14 pin LCD display with a Hitachi HD44780 driver. The down side was there was no data sheet with the screen so I've been using standards found on google.

So far,  when i fire it up I can only get 1 row out of the two to light up with solid squares. Does this mean the screen is faulty or have I miss connected one of the leads?
the second mystery comes when I use the liquid crystal tutorial, the squares are wiped off the screen and I am no longer able to see ANYTHING ( the print didnt work..)

any suggestions are much appreciated..
Logged

Global Moderator
Offline Offline
Brattain Member
*****
Karma: 498
Posts: 19064
Lua rocks!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

From memory, one row is normal, at least for me. As for why it went blank, that is another question. But I wouldn't worry about one row of boxes.
Logged


Global Moderator
Offline Offline
Brattain Member
*****
Karma: 498
Posts: 19064
Lua rocks!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Besides, this is the LED section, not the LCD one. There have been heaps of discussions recently about getting LCDs to work. smiley
Logged


North Yorkshire, UK
Offline Offline
Faraday Member
**
Karma: 104
Posts: 5531
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
From memory, one row is normal, at least for me.
This is normal.

Have you got the enable and r/w lines connected up correctly>
Logged

Pages: [1]   Go Up
Jump to: