Go Down

Topic: Error while uploading (Read 4579 times) previous topic - next topic


Yesterday when i uploaded the sketch to my arduino uno it worked fine but when today i tried to upload the sketch i got this error

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

What does that mean ?


I'm having the same problem..  :smiley-slim:
this is the error I get when i try to upload the sketch...

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x41

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x41
avrdude: stk500_set_extended_parms(): protocol error, expect=0x14, resp=0x45
avrdude: stk500_initialize(): failed


The problem was that i selected wrong serial COM port


There is no problem with the com port.... I'm still unable to upload my sketches...  :(
I'm still a novice.. any help would be appreciated... :smiley-fat: 


See i unplugged the arduino cable and again plugged it in and checked which port it uses and then selected that com port no. in the arduino software and it worked.


i tried that several times... no use... :(
Could there be a problem with my arduino board????


I dont know that if the problem is in your arduino or not
was there any other device attached to your pc alongwith arduino e.g ipod,etc
Because when i got this error i had my ipod attached to the pc and when i removed the ipod and again tried it worked.
I really dont know that it was because of that ipod but you can try this.


Problem Solved!!!  XD
The problem was with my hardware...  :(
got the atmega8 controller changed... now everything is working fine..  :)

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131