Pages: [1]   Go Down
Author Topic: Error while uploading  (Read 1636 times)
0 Members and 1 Guest are viewing this topic.
India
Offline Offline
Newbie
*
Karma: 0
Posts: 37
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello,
Yesterday when i uploaded the sketch to my arduino uno it worked fine but when today i tried to upload the sketch i got this error

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

What does that mean ?
Logged

Bangalore
Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm having the same problem..  smiley-slim
this is the error I get when i try to upload the sketch...



avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x41

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x41
avrdude: stk500_set_extended_parms(): protocol error, expect=0x14, resp=0x45
avrdude: stk500_initialize(): failed
Logged

India
Offline Offline
Newbie
*
Karma: 0
Posts: 37
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Resolved
The problem was that i selected wrong serial COM port
Logged

Bangalore
Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

There is no problem with the com port.... I'm still unable to upload my sketches...  smiley-sad
I'm still a novice.. any help would be appreciated... smiley-fat 
Logged

India
Offline Offline
Newbie
*
Karma: 0
Posts: 37
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

See i unplugged the arduino cable and again plugged it in and checked which port it uses and then selected that com port no. in the arduino software and it worked.
Logged

Bangalore
Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

i tried that several times... no use... smiley-sad
Could there be a problem with my arduino board????
Logged

India
Offline Offline
Newbie
*
Karma: 0
Posts: 37
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I dont know that if the problem is in your arduino or not
was there any other device attached to your pc alongwith arduino e.g ipod,etc
Because when i got this error i had my ipod attached to the pc and when i removed the ipod and again tried it worked.
I really dont know that it was because of that ipod but you can try this.
Logged

Bangalore
Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Problem Solved!!!  smiley-lol
The problem was with my hardware...  smiley-sad
got the atmega8 controller changed... now everything is working fine..  smiley
Logged

Pages: [1]   Go Up
Jump to: