Go Down

Topic: RX/TX Issues... (Read 838 times) previous topic - next topic

phate

Mar 09, 2011, 03:46 am Last Edit: Mar 09, 2011, 04:13 am by phate Reason: 1
I'm not entirely sure whether this should go in the Processing forum or the Arduino forum, but here goes. I was having some serious issues regarding data integrity over the serial connection between Processing and my Arduino. Finally, I realized that it was because Processing was having a conflict with my RX/TX drivers. I updated the drivers, and all of my problems were solved. Or so I thought...

Well, my Processing code worked, so now it was time to make some additions to the code I had running on the Arduino. Except...the Arduino environment crashes every time I go to upload code.

My best guess is that updating my RX/TX drivers broke the Arduino dev environment. I need the old drivers to upload my code to the Arduino, but I need the new ones so that I can communicate with it. Of course, I don't even know what version Arduino was using.

I am stuck between a rock and a hard place. Can anyone help me? Is there any way to load different RX/TX drivers in Arduino and Processing? Can I get Arduino to play nice with the new drivers? (rxtx2.2pre2)


P.S. The error report won't fit. Not sure how to include it.


:edit: I deleted my RX/TX files entirely, and now everything is fixed. I guess Processing and Arduino come with their own drivers to fall back on just in case the user screws something up royally. :/edit:

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy