Go Down

Topic: Help Genuino Zero fails to upload bootloader (Read 252 times) previous topic - next topic

MicheleMaris

Hi
I have a problem with my Genuino ZERO

I am working with IDE 1.8.5 on Linux UBUNTU

I compile a simple sketch, as an example: BLINK, it refuses to upload through the Programming port.

I selected:

Board:
Arduino/Genuino Zero (Programming Port)

Port:
/dev/ttyACM0/Arduino/Genuino Zero (Programming Port)

Programmer:
Atmel EDGB

It returns the following errore message:

Arduino: 1.8.5 (Linux), Board: "Arduino/Genuino Zero (Programming Port)"

/home/maris/bin/arduino-1.8.5/arduino-builder -dump-prefs -logger=machine -hardware /home/maris/bin/arduino-1.8.5/hardware -hardware /home/maris/.arduino15/packages -tools /home/maris/bin/arduino-1.8.5/tools-builder -tools /home/maris/bin/arduino-1.8.5/hardware

Using board 'arduino_zero_edbg' from platform in folder: /home/maris/.arduino15/packages/arduino/hardware/samd/1.6.15
Using core 'arduino' from platform in folder: /home/maris/.arduino15/packages/arduino/hardware/samd/1.6.15

Generating function prototypes...
Compiling sketch...
Compiling libraries...
Compiling core...
Using previously compiled file: /tmp/arduino_build_44982/core/variant.cpp.o
Using precompiled core
Linking everything together...
Open On-Chip Debugger 0.9.0-g932ec70 (2017-02-15-11:32)
Licensed under GNU GPL v2
An error occurred while uploading the sketch
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
debug_level: 2
Info : only one transport option; autoselect 'swd'
adapter speed: 500 kHz
adapter_nsrst_delay: 100
cortex_m reset_config sysresetreq
Error: unable to open CMSIS-DAP device 0x3eb:0x2157
Error: No Valid JTAG Interface Configured.

In practice It seems the IDE is not able to connect to the board.

I google on the web that this kind of problem could be caused by a corruption of the bootloader, so I attempted at reloating the bootloaded.

This is the result:

Arduino: 1.8.5 (Linux), Board: "Arduino/Genuino Zero (Programming Port)"

http://openocd.org/doc/doxygen/bugs.html
debug_level: 2
Info : only one transport option; autoselect 'swd'
adapter speed: 500 kHz
adapter_nsrst_delay: 100
cortex_m reset_config sysresetreq
Error: unable to open CMSIS-DAP device 0x3eb:0x2157

Error while burning bootloader.

Do you have any suggestion about this?  :o

Or do I have to consider my board dead and good to be trashed out?  :'(

Thank you very much
Michele

gdsports

I am also using IDE 1.8.5 on Ubuntu. I suggest trying to upload the blink sketch via the native USB port. Perhaps the programming port is broken.

Upgrading to the latest SAMD board package, which is 1.6.18 on my system, might help.

MicheleMaris

Hi, I did the upgrade to 1.8.6 and it worked
also I have had to install an UDEV rule as explained by

https://arduino.stackexchange.com/questions/28566/arduino-zero-error-unable-to-find-cmsis-dap-device

http://bitofahack.com/post/1437909576

thank you very much
mic

Go Up