Pages: [1]   Go Down
Author Topic: Arduino + EasyDriver weird power question  (Read 1272 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 14
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hello,

I thought I understood how the wiring should be between the arduino and the easydriver, but when things didn't work out, I moved a ground connection, unplugged the USB cable from the Arduino, and happened upon an odd result. Here is a crude layout of how it is currently wired.



The odd thing is that this wiring gives power to both the EasyDriver AND the Arduino.  Everything seems to run fine, the motor moves as it should, and nothing smells like smoke.  I was under the impression that the M+ on the EasyDriver only fed power to the motor, and that the 5v on the Arduino isn't meant to work as a power input. Am I missing something here? Is it safe to leave it wired like this?

Thanks guys!
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 14
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ok, I did a little research to refresh my understanding as it's been a few months since I looked this stuff up. It appears I've misremembered a lot of it.  Apparently the 5v connection on the EasyDriver is an output, and the 5v on the Arduino is an input. This, of course, means that everything is working exactly as it should.  Power comes from 9v power supply, the EasyDriver puts out a regulated 5v which powers the arduino via the 5v connection.  Sorry for my confusion =)
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 14
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hmm...  Now I'm reading over the documentation again and I'm changing my mind about the 5v connection on the Arduino.  It sounds to me like this is supposed to supply voltage to power other 5v boards and gets its power from either the USB or Vin or power connector.  While it seems to work when the power is fed to this pin, I think I'll be safer feeding the 5v into the Vin instead.  Please feel free to correct/approve any of my statements.  Thanks =)
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Have you tried this? because i think the two pins you marked on the Arduino are output pins. i'm wondering if those two pins could be used to supply the EasyDriver instead.
Logged

Leighton Buzzard, UK
Offline Offline
Edison Member
*
Karma: 21
Posts: 1339
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

there is a little track you can cut on the EasyDriver to disable the onboard 5v, which is indeed derived from motor power
you can then power it from the Arduino (or any other 5v supply)

why would you do that?
well with 9 volt motor power the regulator doesn't have to work too hard
with 30 volts it does get quite warm! (it's dissipating 30-5=25 volts at whatever current you are drawing)

with the onboard 5v enabled, you can draw (up to 50mA as I recall) power to drive, for example, the Arduino

too many options!
Logged

there are only 10 types of people
them that understands binary
and them that doesn't

Pages: [1]   Go Up
Jump to: