Pages: [1]   Go Down
Author Topic: Conexión USB con librería SoftwareSerial  (Read 1325 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 12
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Buenos días.

Estoy haciendo un programa para recibir la información de las sentencias NMEA de un GPS mediante la entrada de un puerto rx,tx con la librería SoftwareSerial y enviarlas a una tabla sql de internet mediante una placa ethernet.

Tengo el código sin problemas y funciona correctamente pero deja de funcionar si desconecto el arduino del puerto USB y lo dejo simplemente con la alimentación externa, es como sino fuera capaz de recibir la información y mandarla, solo me pasa si utilizo el sensor GPS, con otras placas con otros sensores los envía correctamente siempre.

¿Os ha pasado alguna vez lo mismo?

Saludos smiley-eek
Logged

0
Offline Offline
Edison Member
*
Karma: 8
Posts: 1040
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Lo tienes conectado en el pin RX?

Salu2
Logged

Trabajando en ...

    * Control Domotico (En montaje ...)
    http://casitadomotica.blogspot.com/
 

[url=https://bitbucket.org/fmalpartida

0
Offline Offline
Newbie
*
Karma: 0
Posts: 12
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Gracias por contestar.

Lo tengo conectado a los pines 12 y 13, creo recordar que la placa ethernet utilizaba los primeros pines rx y tx.

Saludos smiley-eek
Logged

0
Offline Offline
Edison Member
*
Karma: 8
Posts: 1040
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Que placa de arduino estas usando.
Saludos.

Logged

Trabajando en ...

    * Control Domotico (En montaje ...)
    http://casitadomotica.blogspot.com/
 

[url=https://bitbucket.org/fmalpartida

0
Offline Offline
Newbie
*
Karma: 0
Posts: 12
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Estoy utilizando una placa antigua duemilanove, pero tengo otras nuevas UNO también.

¿Crees que puede ser problema de la versión de la placa?

Saludos smiley-eek
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 12
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

CONSEGUIDO!

Era problema de la placa duemilanove, con una placa arduino UNO, funciona a la perfección. Realmente nose a que es debido el problema pero con las nuevas placas UNO se ha solucionado.


Un saludo y gracias smiley-eek
Logged

Pages: [1]   Go Up
Jump to: