Go Down

Topic: attiny85 fail - please help (Read 2456 times) previous topic - next topic


I am sittin'g in front of my computer for several hours and trying to upload program from my Arduino Duemilanove to my cheaper processor attiny85-20pu but it's not happening. I have wired the cables accord schematics on http://hlt.media.mit.edu/wiki/pmwiki.php?n=Main.ArduinoATtiny4585 . I hope i've done everything correctly but still i've got an error report. It says: "avrdude: stk500_getsync(): not in sync: resp=0x15". I ve got 2 of those processors and  not even one of them is working. I don't know what am i doing wrong. I use arduino 0022. I am uploading ArduinoISP first on my processor ATMEGA328P and after that i am allways picking "tools -> Board -> ATtiny85 (w/ Arduino as ISP)" and upload  "modified" blink-ing. I don't know what is wrong please take a look at it and help!!!! I am literaly begging...thank you very much for any advice.


Mar 13, 2011, 02:23 am Last Edit: Mar 13, 2011, 02:27 am by bHogan Reason: 1
And after loading the ArduinoISP you disabled reset so it won't reset when you load the ATtiny85 sketch?

It's right there in the toutorial - oh wait! - it's not! Just a small omission that has caused, and will cause, hours of frustration for those not in on the secret.

See . . .
"Data is not information, information is not knowledge, knowledge is not understanding, understanding is not wisdom."
~ Clifford Stoll


OK. I've tried this method also but there will pop-up another problem. I will describe you my whole procedure.  I take my arduino, taking pin 13 on pin 7 on ATtiny (SCK: ATtiny Pin 2), pin 12 on pin 6 (MISO: ATtiny Pin 1), pin 11 on 5 (MOSI: Arduino Pin 0) and last one pin 10 on pin 1 (reset). Fine, after that i attach power and ground and at last on your advice, I've attached 120ohm resistor betwen +5V and reset. And than it will show another mistake.

avrdude: please define PAGEL and BS2 signals in the configuration file for part ATtiny85
avrdude: Yikes!  Invalid device signature.
         Double check connections and try again, or use -F to override
         this check.

I don't have any idea what am I doing wrong. Thanks for any advice.


I suggest you download winavr here:

then try uploading using avrdude. you have to use commandline... you can find many tutorials for this, like this one:

post what happens after that step


It works perfectly, thanks. I tried one more time the thing with resistor and it worked also. The problem was that i had about 1 meter long cable and put the resistor behind it. When i've done it it showed the errors. But when i plugged directly on arduino it worked. Maybe capacitance and resistance done its thing maybe not. Anyway it works perfectly both way. Thank you very much.

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131