Pages: [1]   Go Down
Author Topic: Uno board 38400 baud rate  (Read 1248 times)
0 Members and 1 Guest are viewing this topic.
Colorado
Offline Offline
Full Member
***
Karma: 2
Posts: 220
Arduino 0022 and Ubuntu 11.10 64bit.
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi, I have a Uno board, arduino-0022 and my operating system is Ubuntu 11.04.  Nothing is attached to the Uno board.  The board is running the upgraded 8U2 firmware and the new bootloader and here is the sketch I am uploading.  The sketch uploads and runs fine for every baud rate (4800-115200) except for 38400.  If I change the monitor baud rate to 38400 the board remains selected in the ide, but the port is now greyed out.  The device /dev/ttyACM0 is still functioning (screen /dev/ttyACM0 works). I can upload the sketch with the serial.begin(38400), but as soon as I change the monitor baud rate to 38400 it no longer functions. Uploading the sketch with Serial.begin(38400), terminating the ide and then running screen /dev/ttyACM0 38400 works. In the ide changing the monitor baud rate back to 9600 or any other baud rate (except for 38400) does not work.  It order to fix it, I have to terminate the ide, unplug the board, and edit the preferences.txt file and change the serial.debug_rate to 9600 and restart the ide.

Code:
void setup() {
  Serial.begin(38400);
}

void loop() {
 Serial.println("test");
}

Here is the error I get when I change the baud rate in the monitor
Quote
Binary sketch size: 1890 bytes (of a 32256 byte maximum)
processing.app.SerialNotFoundException: Serial port '/dev/ttyACM0' not found.  Did you select the right one from the Tools > Serial Port menu?
   at processing.app.Serial.<init>(Serial.java:153)
   at processing.app.Serial.<init>(Serial.java:76)
   at processing.app.debug.Uploader.flushSerialBuffer(Uploader.java:75)
   at processing.app.debug.AvrdudeUploader.uploadViaBootloader(AvrdudeUploader.java:93)
   at processing.app.debug.AvrdudeUploader.uploadUsingPreferences(AvrdudeUploader.java:56)
   at processing.app.Sketch.upload(Sketch.java:1603)
   at processing.app.Sketch.exportApplet(Sketch.java:1568)
   at processing.app.Sketch.exportApplet(Sketch.java:1524)
   at processing.app.Editor$DefaultExportHandler.run(Editor.java:2293)
   at java.lang.Thread.run(Thread.java:636)

Any ideas, except for don't use that baud rate?
« Last Edit: March 14, 2011, 02:54:06 am by mrtaylor » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I've experienced the same with ubuntu 12.04, couldnt select baud rate as 38400.. but its working on windows 7..
Logged

Pages: [1]   Go Up
Jump to: