Go Down

Topic: Eagle Autorouter will not route my board. (Read 4845 times) previous topic - next topic

Mr. Swarf

I'm trying to make a breakout board for a QSOP16 package. I've got the board layout done but cannot get this to autoroute. When I click on the autoroute button it does it's thing and then just sits there saying 0.0% done.

I've even disabled the bottom layer. Any suggestions?

Thank you.
M.S.

mowcius

What tolerances do you have set up?

Why are you using the autorouter anyway? It's so... eugh...

I suggest you go ask on the CadSoft website as they will probably have a better idea about what your issue might be :)

Graynomad

I've never net an autorouter that was worth a pinch of sh!t, and for a breakout board there can't be more than 20 traces to run anyway can there? And they would all be straight from one pin to another right next to it.

______
Rob
Rob Gray aka the GRAYnomad www.robgray.com

RuggedCircuits

The Eagle autorouter is a great tool if used properly.

What do you have set up as the routing grid? When you first click on the Autoroute button, there is a text box in the General tab named "Routing Grid". If that is set too large then Eagle will not be able to connect to your pads. I would suggest setting that to 5 mil to start with.

--
The Aussie Shield: breakout all 28 pins to quick-connect terminals

MarkT

Definitely this is the autorouter grid (which defaults to 0.05 inch and can't route surface mount chips at all  - but looks much neater for through-hole boards).
[ I won't respond to messages, use the forum please ]

JeonLab

If the Eagle auto-router refuse to work at all or less than 100% done, there must be too crowd area which auto-router can not pass all the wires between components.  In such cases, I would move some components to where less crowd area and try it again until the progress is done all the way to 100%.

Personally, I love auto-router of Eagle.  I have used the auto-router function since the version 5.8 or 9, quite recent versions though, and found it worked great.  I have had problems with PCBs with SMDs, but for the through-hole components based PCBs, I would strongly like to recommend to try the auto-router. 
http://jeonlab.wordpress.com/

mowcius

Quote
but for the through-hole components based PCBs, I would strongly like to recommend to try the auto-router.

Well the issue is that it doesn't take things like priority signals into account or the requirements of ground planes in certain places etc etc.

If you're doing starting out and learning then it can be great but otherwise I'd probably stick to manual routing (or at least manually route some of the tracks first)

Go Up