Go Down

Topic: Problema con NRF24L01+PA+LNA (Read 379 times) previous topic - next topic

brazoayeye

Jul 02, 2018, 11:19 pm Last Edit: Jul 02, 2018, 11:22 pm by brazoayeye
Buongiorno a tutti,

sto eseguendo delle prove con dei moduli NRF24L01 e tutto sembra funzionare correttamente in un range molto corto. Quando provo ad aumentare il range usando un modulo come questo riscontro dei problemi non sempre ripetibili.

A volte arduino vede il modulo connesso ma non trasmette neanche a distanze corte, altre volte arduino non si connette al modulo.

La configurazione è la seguente:

Arduino micro alimentato usb
L78L 3.3V per alimentare l'antenna to-82
Connettore di questo tipo dove è collegata l'antenna
Condensatore da 1000uA collegato tra 3.3V e GND nella pcb contenente il regolatore di voltaggio

Secondo voi quale può essere il problema?

Grazie!

brazoayeye

Ciao, qualcuno sa se comprando un modulo originale potrei risolvere o se c'è qualche altro problema?

gpb01

Search is Your friend ... or I am Your enemy !

brazoayeye

Lettura interessante, non sono particolarmente interessato ai consumi e per migliorare la ricezione ho comprato la versione "potenziata".

In ogni caso ho aggiunto un ulteriore generatore in parallelo al primo (sempre 100mA) e ora funziona tutto correttamente. Questa cosa mi sembra abbastanza strana in quanto sono già presenti condensatori abbastanza grandi, ma tant'è...

brazoayeye

Torno con alcuni dubbi sullo stesso argomento.

Alcune informazioni sul software e hardware usato:
  • La comunicazione avviene in broadcast in un solo verso, dal modulo con PA a quelli standard (6 moduli). (ACK disabilitato) Il payload è da 29 char. la velocità di trasmissione 250kbps
  • Tutti i moduli sono posizionati sullo stesso piano, la distanza massima tra l'emettitore e il ricevitore è circa 25m.
  • L'antenna del modulo PA è orientata in modo perpendicolare al piano dove sono posti i moduli
  • Le antenne dei moduli standard sono nella scheda stampata, l'angolo tra la normale alla scheda stampata e la congiungente emettitore-ricevitore è compreso tra 70° e 87° (nell'ultimo caso la congiungente è praticamente parallela alla scheda)
  • Ogni pacchetto inviato include un numero incrementale che mi permette di capire se sono stati persi pacchetti


Su alcune basi ho una perdita fino al 20% dei pacchetti, in modo apparentemente causale. Spostando leggermente l'emettitore vi sono delle variazioni nel numero di pacchetti persi
Se copro con la mano l'antenna dell'emettitore (senza toccarla) ho un aumento MOLTO sensibile dei dati persi (anche sopra il 90% dei pacchetti viene perso)

Ecco le domande

A) Ho letto che payload corti riducono il numero di pacchetti persi, quanto potrebbe migliorare accorciare ad 11 char?
B) Come varia la comunicazione avendo entrambi i moduli con PA, o solo uno dei due con PA? La ricezione viene migliorata dalla versione potenziata?
C) La comunicazione scadente potrebbe essere dovuta all'angolo di posizionamento dell'antenna?
D) Credete sia possibile che moduli cinesi abbiano abbiano comportamenti molto diversi tra loro?
E) Ho letto che è possibile "schermare" il modulo con PA tramite dei fogli di alluminio (prima avvolgerlo in pellicola plastica da cucina, poi alluminio e connetterlo a terra), dite che questo potrebbe migliorare molto il segnale?

Per migliorare la comunicazione ho implementato un sistema di rimbalzo dei pacchetti tra le basi "riceventi", anche se lo devo ancora testare.
Ovviamente se non bastasse andrei ad acquistare un emettitore più di qualità lasciando gli attuali standard scadenti

Grazie!

Go Up