Go Down

Topic: I BROKE IT ? = atmega2560 (Read 217 times) previous topic - next topic

Bastol

so here is the deal .. i have an atmega2560 based board for the vellman vertex k8400 3d printer..
power went out when i was flashing the firmware -  (NOT my printer.. a loaner of sorts)

so now it dont work and with the usbport built on it wont recognize what device it is. to attempt reflash
*usb does find a device tho.. so its breathes a bit*


i am a noob to arduino but it s on my list. .with the broken printer tho i am rushed and not in the mindset to the depth of these forums and docs and etc..

so i need help  just to make it live.. so i can take the atmega2560 i bought off amazon to use as a jump start programmer  to force the new firmware or old firmware on the  printer and make it go

i got the new atmega2560 standard board flashed with the arduino as isp  sketch and it talks..
but when i push the firmware or boot loaders to the printer

-- com3- printer shows this for board id
BN: Unknown board
VID: 0403
PID: 6001
SN: Upload any sketch to obtain it
---
uploading direct to unknown device ( often it doesnt show that id above)
---
Low memory available, stability problems may occur.
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer
An error occurred while uploading the sketch


----using arduino as ip for programmer  on com 4BN: Arduino/Genuino Mega or Mega 2560
VID: 2341
PID: 0042
SN: 55736313437351E02002
----

avrdude: Yikes!  Invalid device signature.
         Double check connections and try again, or use -F to override
         this check.

An error occurred while uploading the sketch

how do i give the - F command using the IDE ?
How do i make the printer go .. im desperate

ill watch the forum and post results here but you can catch me on discord for live and screen sharing etc..
voice and video -or visual inspections/photos ..  mi not a dumbski  but today i am  apparently


catch me live on discord here  https://discord.gg/pJx5xH


HALP PLZ!


Bastol

pluggin a usb to both  and putting com3 baudrate to 9600 ( it was at 115200 for somereason)
 got this instead  -- same thing for uploading firmware/sketch


avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x03
Error while burning bootloader.

Budvar10

Baud rate for Arduino as ISP is 19200.
Do not use -F in any case. Timeout usually means incorrect ISP connection. There are only 6 wires needed so check the connection carefully and try again.
Arduino clone with ATmega1284P   http://forum.arduino.cc/index.php?topic=277260.0

vscelwan

I change the crystal on board to 16MHz,

Change:
mega.menu.cpu.atmega2560.upload.protocol=wiring

To:
mega.menu.cpu.atmega2560.upload.protocol=stk500v2


After that Upload without issue

Go Up