Go Down

Topic: New ethernet shield? (Read 11773 times) previous topic - next topic


I've just received what I thought was going to be an official ethernet shield, but it's a bit different...

It looks like an official shield (colour, made in italy), but it's clearly a different layout to both the V4.0 shield (this has a microSD slot) and the V5.0 shield (almost everything in a different place - only the sockets, connectors and WIZnet chip seem to have stayed put).

The thing I'm interested in is that the RJ45 has ten pins (plus LED connectors), and that screams PoE to me.  Furthermore, pins 9 and 10 have chunky traces on the bottom and pins 7 & 8 have chunky traces on the top out to the row of holes at a (slightly diagonal) 0.1" pitch. 

The jack is marked UDE on the top and RB1-125BHQ1A 1035Eda on the back.  Some googling with that takes me to
where (unfortunately) that part does not exist, though deductions based on other parts data sheets suggests that 1035Eda is just a date code, and the longer number is a part number, within which HQ1 is the designator for the internal circuit layout.  I can't find any jack on the site with an HQ1 circuit.

So, is this a jack with built-in rectifier bridges to extract PoE power?  I actually have some PoE injectors kicking around (both cheapo non-standards that just put whatever you inject as + on 4&5 and - on 7&8 and proper standards-compliant 48V ones) so this would be jolly handy.  If anyone knows the answer, it might save frying something as I try trial-and-error to work it out!

I can't find any reference on the web other than a page on watterott that has a very slightly different (but closer than any other shield I've found) board that is described in passing as "PoE model" and apparently has a reset problem: http://www.watterott.com/en/blog/Upload-problem-with-Ethernet-Shield

Does anyone know what I've got, or have any other comments?  Thanks.


Does anyone know what I've got, or have any other comments?

Did you just find it lying on the side of the road?
Google forum search: Use Google Search box in upper right side of this page.
Why I like my 2005 Rio Yellow Honda S2000  https://www.youtube.com/watch?v=pWjMvrkUqX0


Mar 18, 2011, 05:17 am Last Edit: Mar 18, 2011, 10:05 am by Graynomad Reason: 1
All the real boards (and photos of real boards) I've seen have had much denser screen printing than that. No way you would see the traces through the paint.

Rob Gray aka the GRAYnomad www.robgray.com


All the real boards (and photos of real boards) I've seen have had much denser screen printing that that. No way you would see the traces through the paint.

The board and print colour, texture and style are indistinguishable from the Uno I have.  I have no suspicion that he Uno is not real - it looks the same as every photo I've seen, came in the little printed folded packet with a sheet of sticky labels etc.  I can't see anyone going to the bother of making such an accurate fake.

The lighting and camera have emphasised the texture of the surface and make the traces under printing much more obvious than looking at it under normal lighting with the naked eye.

As to where I got it - Farnell, who describe its manufacturer as Arduino with manufacturer part number A000031 and have a picture of the V5.0 (with their standard caveat that the picture is only indicative): http://uk.farnell.com/arduino/a000031/board-arduino-ethernet-shield/dp/1848680


I'd bet the RJ45 is a MagJack, I have a WIZ811MJ module that has one, with two LEDs built in.  The jack on my official Arduino Ethernet shield has no LEDs.  Your Ethernet shield is significantly different from mine, which came from Adafruit in early January.  Mine looks like the picture there, or the picture on the Arduino site.

Have you tried it, does it work?


OK, since no-one knows anything, I've done some playing.

Firstly, yes it works.  At least, the ethernet works, I haven't tried the card slot.  I've run both the example web server and ntp client and all seems fine.  LEDs on the board light up, and so do the LEDs on the jack face - there's a green one to the left that appears to be traffic, and an orange to the right (towards the row of six holes) that appears to be 100M (but I don't have anything other than 100M lying around to test it with).  There are small SMD LEDs immediately adjacent on the board that do the same thing.  The ones on the board are opposite colours (traffic is orange, 100M is green).

The column of four LEDs by the crystal are link, RX, TX and ON.  Green, orange, orange, green.

Reset button works and resets the arduino.

Now for the interesting bit.  Numbering the row of six holes as 1-6 from the one nearest the board edge as 1 to the one furthest from the edge as 6 and adopting normal RJ45 colour codes (ie as T568B at http://en.wikipedia.org/wiki/TIA/EIA-568-B#Wiring), the holes are:
1: blue pair (ie unused for data)
2: brown pair (unused for data)
3: orange pair (a data pair)
4: green pair (a data pair)

There doesn't appear to be any connections to 5 and 6 (you can see that from the board photos - very short traces to two points just under 2mm spacing).

There are no diodes (no rectifier bridges) in the jack, so far as I can make out.  I detect no diode drops when I inject on pins 4, 5, 7 or 8 of the jack, and whatever polarity I inject comes out on the pads as above.  I think the pads are simply connected to the pins.  Presumably on pins 1, 2, 3 & 6 of the socket it's actually to the centre tap of a coil in the jack (since otherwise the ethernet wouldn't work), but I can't detect that.  I can't tell whether (for example) 4 & 5 are shorted more directly than 1 &2 (cheap multimeter), so don't know if the non-signal pins have coils across them.  Probably not, but that's a guess.

I've had 15V at about 100mA and 3V at about 300mA of power through the pins 4, 5, 7, 8 while traffic flows on the ethernet and it's fine with that.  I decided not to actually try and fry it, so stopped at those levels.  I've had 50V on the pins while traffic flows (but no current draw) and it was likewise happy.  I don't have an injector that will put power on the data pairs (though that's obviously allowed by the standard) and I'm not going to build one just to see if it works - the power injector modules I have just use the non-data pairs anyway.


Hopefully it is a later version that performs more reliably than my version.

If it performs well with out losing or scrambling data please report back.

My unit is not reliable and I would happily buy a new one to end the grief on my current project. A few people have reported these data loss and scrambling problems.


I uploaded the schematics and Eagle files: http://arduino.cc/en/Main/ArduinoEthernetShield.  Apologies for the delay.



I recently bought one official Arduino Ethernet Shield, which look exactly like the one in the first post.
As with every new "toy" I buy, I did some research on this new Shield.

These are my findings:

-Ethernet jack, although not documented, seems to be a pretty standard PoE jack with internal magnetics, with no internal rectifiers for PoE. As defined in 802.3af, power can be injected either on pair 7-8 or RX and TX pairs. This jack supports both - pair 7-8 is routed directly to jack's pins and possibly center taps of RX and TX transformer primary windings are also routed to jack's pins (V1+, V1- and V2+, V2- in the schematics).

-There are 10 unmarked holes on the PCB, 6 near Ethernet jack and 4 between W5100 and SD socket. Let's consider first group of holes near the Ethernet jack as pins 1 to 6 (pin 1 is the leftmost, near the edge of the PCB). Pins 1 to 4 are connected to jack, being V1+, V1-, V2+ and V2-. Pins 5 and 6 are unconnected. The second group of 4 pins, say pins 7 to 10 are, in this order, GND, Vin, ADJ and unconnected. ADJ has a 0 Ohm resistor to Vin.

Now get the following datasheet: http://www.silvertel.com/DataSheets/Ag9400v2-3.pdf
This component pins match Ethernet shield PCB, both electrically and mechanically!
It seems this Shield was designed to use a Silvertel Ag9400 POE module!

Further investigation reveals that possibly an Ag9412-2BR is a good choice - This module nominally outputs 12V, but with the 0 Ohm resistor between pins 8 and 9, voltage outputs drops to 9.8 Volts, which is OK to power arduino 5V regulator.

Unfortunately, I don't have one Ag9412-2BR available at this moment (I only have Ag9403 and Ag9405…) and, although they are very cheap, these modules are not easy to get...

If you have one Ag9412-2BR available, please try it and let us all know your findings!

Pedro Couto


as far as i know, will be released soon a new Arduino Ethernet board.
It will be all-in-one (not a shield) solution, with POE support.
..very very interesting!  XD

Here a image i've done at the ArduinoCamp (www.arduinocamp.com) at 18/06/2011 in Italy, Milan:

Other photos (new Arduino WiFi shield, new Arduino Uno):


Jun 28, 2011, 02:00 pm Last Edit: Jun 28, 2011, 02:04 pm by mowcius Reason: 1
as far as i know, will be released soon a new Arduino Ethernet board.
It will be all-in-one (not a shield) solution, with POE support.
..very very interesting!  smiley-lol

Here a image i've done at the ArduinoCamp (www.arduinocamp.com) at 18/06/2011 in Italy, Milan:

Well after they got to V02 5 years ago back in 2006 with an ethernet board it's been a long time coming:

We were still on the Arduino NG back then...



This all-in-one is very interesting indeed!  ]:D

Judging from the photo, this board will also use a Silvertel PoE module.

I suspect that there are a couple of issues:

-Plugging a shield on top of this "Arduino Uno Ethernet" may be a problem due to PoE module height.
-There is a ferrite core transformer on the PoE module that "sits" right on top of W5100 chip. Although the transformer is a "closed core" type, I'm not sure whether its radiated field will somehow affect W5100 performance/operation (theoretically, in extreme situations, it could cause erratic operation of W5100 chip).

Let's wait for this new board…


Aug 04, 2011, 04:26 am Last Edit: Aug 04, 2011, 04:40 am by LeXLuther422 Reason: 1
It does support PoE but you have to buy a Silvertel PoE Module AG9120S http://arduino.cc/en/uploads/Main/PoE-datasheet.pdf and solder it to the board. Yes it is a 12v module but with a bridge already installed on the Ethernet Shield from V+ to ADJ it supplies 9v to the Arduino it can be used with a power injector that supplies 48v over the data lines or over the extra pairs but not both at the same time.

The module can be found here http://www.semiconductorstore.com/cart/pc/viewPrd.asp?idproduct=13996



I'm a bit of a newbie to Arduino, but I was hoping someone could help me out?

I have the ethernet shield as shown here: http://arduino.cc/en/Main/ArduinoEthernetShield.  According to that page, it supports PoE with the optional module, but I can't find the holes where it's supposed to go.  Has this feature been removed?




Aug 24, 2011, 09:11 pm Last Edit: Aug 24, 2011, 09:15 pm by mowcius Reason: 1

The one pictured is not the latest one.

The latest one with the POE installed looks like this:

Go Up