Go Down

Topic: Problem with microcontroller changing and uploading sketch (Read 539 times) previous topic - next topic

rkarduino

I have Atmega328PU Arduino Uno R3 Board. I want to make Standalone Arduino with Atmega328P-PU, I install bootloader, the blink sketch is working after uploading blink sketch, but I could not upload 4 ch relay sketch.
I could not upload sketch after replacing the pu ic with ppu ic.
How to burn sketches in Atmega328P-PU ic on my Atmega328P U board by replacing the said IC.
Does PU IC board supports P-PU IC??????

pert

Please do this:
  • File > Preferences > Show verbose output during: > compilation (uncheck) > upload (check) > OK
  • Sketch > Upload
  • After the upload fails you'll see a button on the right side of the orange bar "Copy error messages". Click that button.
  • Paste the error messages in a reply here USING CODE TAGS (</> button on the toolbar).


rkarduino

My board ic is atmega328pu, can I use atmega328p-pu in the board and upload programme easily?

I installed bootloader from my pu board to standalone p-pu ic.

Should I change it??

pert

The ATmega328 and the ATmega328P are pin compatible so a board that works with one will work with the other. However, the chips have different signatures so you can't use an Arduino IDE board definition for the ATmega328P with the ATmega328. It's not a hardware issue, it's a software issue. You can add support for the ATmega328 to the Arduino IDE easily by installing MiniCore:
https://github.com/MCUdude/MiniCore

Whether the different chip signatures is the cause of your problem I can't say because you haven't provided enough information. That's why I asked you to provide the full error output in my last reply.

rkarduino

My board ic is Atmega328P U.
I want to use Atmega328P-PU IC.
What to do to use it.

pert

I'm not familiar with the ATmega328P U. I had assumed you were talking about the ATmega328-PU vs. ATmega328P-PU. There is no mention of an ATmega328P-U in the datasheet for the ATmega328P. I did find mention of that chip marking in this thread:
https://www.avrfreaks.net/forum/atmega328-chip-markings-initial-program-memory-and-flags-state-ids
So it seems this is a thing but even on avrfreaks nobody knew what that was. Either of westfw's hypotheses sound plausible. In that thread it's indicated that the chips both have the same signature so my previous statement would not apply. The part of the model number after the - refers to IC package, packaging, and RoHS compliance so hopefully there should be no important difference between the chips for your application but in the absence of of any documentation about this mystery "ATmega328P U" that's anyone's guess.

rkarduino

Ok. Then how to run the P-PU chip in my Board which is P U installed by replacement of the chip????

pert

To prevent any possible confusion, please use complete and exact model numbers when referring to parts. For example:
ATmega328P-PU
ATmega328P-U

That tiny extra amount of time typing can save a lot of wasted time caused by a misunderstanding.

Regarding your question, you need to provide the complete verbose output, as I have already requested multiple times.

rkarduino

My atmega328p-pu has blink program i uploaded. But no new program is not being uploaded in it, resp 0x25, 0xe8. Is my chip burnt/ locked? How to determine that.

pert

Why are you so resistant to following my instructions?
Please do this:
  • File > Preferences > Show verbose output during: > compilation (uncheck) > upload (check) > OK
  • Sketch > Upload
  • After the upload fails you'll see a button on the right side of the orange bar "Copy error messages". Click that button.
  • Paste the error messages in a reply here USING CODE TAGS (</> button on the toolbar).


DrAzzy

How to determine that.
The next step depends completely on the error you get. It could be a problem with your computer, it could be a problem with the IDE installation, it could be a problem with your board...

Please follow Pert's instructions and we can direct you as to what to do next. You should *always* post the full text of any and all error messages when asking for help with a technical problem.
ATtiny core for 841+1634+828 and x313/x4/x5/x61/x7/x8 series Board Manager:
http://drazzy.com/package_drazzy.com_index.json
ATtiny breakouts (some assembled), mosfets and awesome prototyping board in my store http://tindie.com/stores/DrAzzy

rkarduino

Dear all.
I am new in Arduino Projects to make some gadgets.
But I need to know something about it.


I have bought an Arduino Uno R3 (Clone) from Local market. The Chip in it is Atmega328P U, (if I know I'll get Atmega328P-PU).
I also bought 4 pcs of Atmega328P-PU Chip and installed bootloader in 2 chips using Breadboard.


When I wanted to install bootloader as Arduino as ISP from original Atmega328P U chip, it succeeded.
I changed the Arduino Chip Atmega328P U with Atmega328P-PU and tried to use as Arduino as ISP to install Bootloader to another Atmega328P-PU chip, it said "invalid signature".

I wish to make one of Atmega328P-PU chip as the original Arduino Uno Board Chip, which is now Atmega328P U, so that all Atmega328P-PU chip I'll buy, can install bootloader/sketch without any error.

Will I make some changes to do so?

What to do. Please give me suggession.
----------------------------------------------------------------------------------------
Another 2 Atmega328P-PU chips has bootloader installed and blink programme installed, but when I want to install another sketch, uploading is freezed for a long time after Tx and Rx light blown for a few miliseconds then stopped, then I close the IDE.

What is the cause for it, Is the chips damaged?

Can I make blank the chips and reinstall bootloader and sketche to this chips again.

Please give me suggestion for this too.

Thanking you.

pert

DON'T CROSS POST!!!!!!!!!!!!!!!!!!!!
http://forum.arduino.cc/index.php?topic=557393
I HAVE REPORTED THIS THREAD TO THE MODERATORS

Why did you start a new thread?

I tried and tried to get you to simply provide the information necessary for us to help you in the other thread but you simply won't do it. It's almost as if you don't want your problem solved.


Go Up