Go Down

Topic: Problem in Connecting Arduino with usb (Read 199 times) previous topic - next topic

felix001

Jul 10, 2018, 03:23 pm Last Edit: Jul 10, 2018, 03:48 pm by felix001
Hi
I plugged my Arduino with USB and when I tried to upload any Program this appears:


Arduino: 1.6.10 (Linux), Board: "Arduino/Genuino Uno"

Sketch uses 928 bytes (2%) of program storage space. Maximum is 32,256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2,039 bytes for local variables. Maximum is 2,048 bytes.
avrdude: ser_open(): can't open device "/dev/ttyACM0": No such file or directory
Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.


I using ubuntu 16.4 and allready tried those commands:


sudo usermod -a -G tty yourUserName
sudo usermod -a -G dialout yourUserName


but without sucess.
I also tried running arduino IDE as root but it return twelve times this

(java:6507): GLib-GIO-CRITICAL **: g_dbus_connection_register_object: assertion 'G_IS_DBUS_CONNECTION (connection)' failed



I think the Problem is that I can't switch to "Serial Ports" and select any USB port.
But how else could I change that?
What else could I do?
Thank you for helping.

ieee488


felix001

the lsusb lists the arduino so it seems like the computer would find it but has got any other problem

gdsports

See if this helps. If not, post the output from the various commands such as lsusb, dmesg, etc. Try a different USB cable, try IDE 1.8.5, etc.

https://majenko.co.uk/blog/diagnosing-arduino-problems-linux


ieee488

Linux Mint 18
IDE 18.3
works!
/dev/ttyCM0

felix001

Thank you very much.
It's working now.

Go Up